networking.service failed.....exited with error code

Discussion in 'Installation/Configuration' started by matt88, Sep 13, 2017.

  1. matt88

    matt88 New Member

    hi guys I'm in need of some help ive ran Linux servers in the past thanks to the tutorials for this website, but ive never came across this problem.
    I bought a cheap hp microserver n54l installed 2 1TB hard drives ive followed this tutorial
    the only change I made to the install was running the server with soft raid 1.
    I got upto nano /etc/network/interfaces and placed the same settings as the tutorial
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    source /etc/network/interfaces.d/*
    # The loopback network interface
    auto lo
    iface lo inet loopback
    # The primary network interface
    auto ens33
    iface ens33 inet static
    the problem I had here is do I need to place the netmask, gateway from my isp or my router settings so I just copied the same settings and hope its right.
    I then service networking restart
    and got the following error Job for networking.service failed because the control process exited with error code. See "systemctl status networking.service" and "journalctl -xe" for details.

    Ive googled, bing and searched forums for a fix but there is so many different fixes I don't know whats right or wrong so I'm hoping someone would be nice enough to help. The server is being used to host a car club so needs to be online soon. I should of stayed with my old setup but it has to be done.
  2. matt88

    matt88 New Member

    anyone surely this is not the first time this problem has arised.
  3. Restart the service and then paste the logs from following commands,
    systemctl status networking.service
    journalctl -xe

Share This Page