Networking problems when moving an Ubuntu 7.10 server

Discussion in 'Installation/Configuration' started by zetnsh, Jan 21, 2009.

  1. zetnsh

    zetnsh New Member

    Hi there,

    I've just purchased a new Intel Atom 330-based machine to replace a development server of mine, which is up and running fine with Ubuntu 7.10. Whilst technically I could plug a CD drive into it and reinstall, I really wanted to stick with the existing install if possible, to save time.

    To cut a long story short, the server is currently running on temporary hardware - indeed Linux seems very forgiving here - new motherboard etc. However, I've ghosted onto the new hard disk of the new server, and it boots up fine, but I get no network connectivity.

    Initially I thought this was because the system just didn't recognise the NIC, but dmesg reveals:

    eth0: RTL8168B/811b... (presumably based on some sort of Realtek chipset)

    I checked /etc/network/interfaces, and sure enough there is a correctly formatted entry for eth0, but ifconfig reveals the interface just isn't there, and

    ifup eth0

    just gives

    eth0: ERROR while getting interface flags: No such device

    However, ifconfig does show a mysterious eth3 with no IP address, saying something about being FIBER, and having a link which is supposedly up. I'm seeing that even now with the LAN cable disconnected. Very wierd.

    Sorry I can't copy/paste anything, the machine of course isn't networked.

    Anyone got the first clue as to what's going on? In all my years of system administration, I've never seen anything like this before!

    Thanks,

    Neil Hamilton
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to replace eth0 with eth3 in /etc/network/interfaces?
     
  3. zetnsh

    zetnsh New Member

    Hi Falko, thanks for replying :)

    Yes - I tried that (seemed obvious really) but I got the same sort of error, implying the device wasn't there. It certainly didn't exist in /dev, although eth0 did. Very very strange. Again, sorry for the lack of a verbose error message - unless I try to get a TTY on a com port and copy/paste from that, I've no easy way other than manual typing...

    I'm wondering whether I've stumbled across some bizare driver bug or something, never seen anything like this in all my years doing server admin, and I have built a lot of Linux boxes in that time!

    My next step is probably to try and boot from an Ubuntu 8.10 live CD and see if that detects the interface properly, and if it does, I'll attempt an upgrade. I might try the same trick with 7.10 first, to see if upgrading would solve it.

    Why do I always find the awkward questions :)

    Thanks again, Neil
     

Share This Page