network problem

Discussion in 'Server Operation' started by nenad, Mar 10, 2008.

  1. nenad

    nenad ISPConfig Developer ISPConfig Developer

    Hi,

    This is one of those problems when solution is right in front of my eyes but I am so tired that I don't see even a white cat.

    Anyway, my router gone out of order so I bought new one. And then, moreover, my ISP changed my static IP (some strange explanation that they had to do so because of new MAC address of my new router).

    So, I changed everything I had to change in router, ISPConfig etc., etc.

    And even all of my websites are visible, dns servers are functional, email is doing fine I have one BIG problem:

    Apt-get can't RESOLVE. ping neither.

    Now comes the strange part. I have a backup server (server200). Same Debian Etch box. Same ISPConfig. Same everything. And on backup machine everything works fine. ping, dig, apt-get etc.

    Now, what I need is additional pair of eyes who are going to tell me what I done wrong.

    For the beginning here is my /etc/network/interfaces (from troublesome server201). It's the same as /etc/network/interfaces file from server200 besides LAN IP address.


    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 192.168.123.201
    netmask 255.255.255.0
    network 192.168.123.0
    broadcast 192.168.123.255
    gateway 192.168.123.254
     
  2. nenad

    nenad ISPConfig Developer ISPConfig Developer

    strange redorection

    P.S. when I posted previews post as soon as I hit "submit reply" button I was redirected to some "contact us " page which one claiming that "no thread wa specified" ???

    Please check attached picture.
     

    Attached Files:

    Last edited: Mar 10, 2008
  3. nenad

    nenad ISPConfig Developer ISPConfig Developer

    Well I found what was a problem:

    in /etc/resolv.conf

    there was

    Code:
    search sbb.co.yu
    nameserver 192.168.123.254
    
    which was obiously not enought so I manually added IP addresses of my ISP DNS servers, so now it looks like:

    Code:
    search sbb.co.yu
    nameserver 192.168.123.254
    nameserver 82.117.194.2
    nameserver 82.117.194.3
    
    and now it works.

    I got that idea when I was reviewing this manual:

    http://howtoforge.com/perfect_setup_debian_sarge_p3
     
  4. falko

    falko Super Moderator ISPConfig Developer

    It was a problem with our load balancer configuration. Session-stickyness wasn't working. I've fixed it. :)
     

Share This Page