Network Connectivity on a Virtual Machine

Discussion in 'Installation/Configuration' started by dayjahone, Jan 27, 2014.

  1. dayjahone

    dayjahone Member

    I'm trying to follow the perfect setup on a debian wheezy virtual machine. I added a static IP, but I can't get it to connect to the network. I have the virtual machine's Network Connection settings set to "Bridged: Connected directly to the physical network" and "Replicate physical network connection state" is unchecked since it's not a mobile device. Anyone know what these settings should be or what I might be doing wrong?
  2. dayjahone

    dayjahone Member

    I can ping IP addresses from the machine, but not domains. Is it a DNS issue since I also can't connect to for updates?

    The following is the result from 'netstat -s':

    Last edited: Jan 27, 2014
  3. Arjen

    Arjen New Member

    Seems like an dns issue. Try to set the nameserver to google and try again

  4. dayjahone

    dayjahone Member

    Thanks, Arjen, but I'm not sure how to do that. The following is my /etc/network/interfaces:

    and my /etc/hosts:

    Code:       localhost.localdomain   localhost  vserver
    # The following lines are desirable for IPv6 capable hosts
    ::1     localhost ip6-localhost ip6-loopback
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
  5. Arjen

    Arjen New Member

    I know this is not the way to go on ubuntu but a quick google learned me that you have to edit /etc/resolv.conf

    Make it look like this


    Then restart network services and try again. See if you can do a ping If so then it was an dns related issue. You could change the DNS to your ISP dns afterwards.
  6. dayjahone

    dayjahone Member

    Thanks! That worked. One more question, however: how do I figure out my ISP's dns? I have a static IP for this machine and a gateway IP address?
  7. dayjahone

    dayjahone Member

    I have another server that runs ubuntu, and I took them from that machine's resolv.conf file. It seems to have worked.

Share This Page