Network Configuration Server - Ubuntu 10.04

Discussion in 'HOWTO-Related Questions' started by Alf71, Oct 9, 2010.

  1. Alf71

    Alf71 New Member HowtoForge Supporter

    Hi

    Thanks for this nice work.
    However, I'm having a problem.
    After installing Ubuntu server 10.04 and configuring the network (point 7, page 3, http://www.howtoforge.com/perfect-server-ubuntu-10.04-lucid-lynx-ispconfig-3-p3)

    I cannot move further

    vi /etc/network/interfaces

    and than

    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 192.168.0.100
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.1

    /etc/init.d/networking restart

    Nothing happens...
    How do I move further and get out of the network configuration window?

    Best regards!

    Alf71 :D
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are you sure that these are the correct network settings for your network? What's your router's internal IP address?
     
  3. Alf71

    Alf71 New Member HowtoForge Supporter

    IP address

    Hi

    IPv4-Adresse . . . . . . . . . . : 192.168.0.100(Bevorzugt)
    Subnetzmaske . . . . . . . . . . : 255.255.255.0
    Lease erhalten. . . . . . . . . . : Sonntag, 10. Oktober 2010 19:41:49
    Lease läuft ab. . . . . . . . . . : Sonntag, 17. Oktober 2010 19:44:07
    Standardgateway . . . . . . . . . : 192.168.0.1
    DHCP-Server . . . . . . . . . . . : 192.168.0.1

    I have other problem:

    Following the tutorial I cannot move further after installing text editor
    and inserting the command

    vi /etc/network/interfaces


    in order to change DHCP into static.
    How do I move further and get out of this network configuration window?
    "/etc/init.d/networking restart" didn't work:

    "Point 7 Configure The Network
    Because the Ubuntu installer has configured our system to get its network settings via DHCP, we have to change that now because a server should have a static IP address. Edit /etc/network/interfaces and adjust it to your needs (in this example setup I will use the IP address 192.168.0.100):

    vi /etc/network/interfaces

    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet static
    address 192.168.0.100
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.1

    Then restart your network:

    /etc/init.d/networking restart"



    Best regards
     
    Last edited: Oct 10, 2010
  4. falko

    falko Super Moderator ISPConfig Developer

  5. Alf71

    Alf71 New Member HowtoForge Supporter

    Thanks - Ubuntu x Virtual Box x Windows x Networking

    It works :D

    One more question:

    Today I installed the new Ubuntu Server 10.10 in my PC, running the latest version of VirtualBox on Windows 7 Ultimate 64 bit.

    I was curious to find if it is possible to access the server from outside:

    WORLD => INTERNET => ROUTER => PC => VIRTUAL PC => SERVER

    Quite confusing all this:

    NETWORK

    So, first of all, I need to get a DDNS name.
    I already have it: server.athome.com
    It is pointed to a dynamic IP address, for example "0.0.0.0"

    My router gateway works on 192.168.0.1 and my PC has a reserved static IP,
    say 192.168.0.155

    I cannot get through from outside of the network, to access my PC, so I thought, if I install UBUNTU SERVER 10.10 in a VirtualBox on it, I will be able to do it...

    After installing my Ubuntu in VirtualBox, I tried to follow this part:

    http://www.howtoforge.com/perfect-server-ubuntu-10.10-maverick-meerkat-ispconfig-3-p3

    vi /etc/network/interfaces
    i
    auto eth0
    iface eth0 inet static
    address 192.168.56.100
    netmask 255.255.255.0
    network 192.168.56.101
    broadcast 192.168.0.255
    gateway 192.168.56.1

    ESC
    :x

    /etc/init.d/networking restart


    vi /etc/hosts
    i

    127.0.0.1 localhost.localdomain localhost
    192.168.0.1 CRAZY-PC.server.athome.com CRAZY-PC

    # The following lines are desirable for IPv6 capable hosts
    ::1 localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters

    I think I need to change first the value
    192.168.56.1 to 192.168.56.100

    but I'm getting a READ ONLY WARNING...

    And before it didn't work at all at:

    aptitude update

    Any hint?

    Best regards

    Alf71:D

    [​IMG]
     
    Last edited: Oct 14, 2010

Share This Page