Network Card Bonding On CentOS - Setup Question

Discussion in 'HOWTO-Related Questions' started by BlahBlah, Aug 22, 2007.

  1. BlahBlah

    BlahBlah New Member

    I have been trying to setup network card bonding on my CentOS server, and I must be missing something, because I cannot get it to work... At all.

    My server has two onboard 10/100/1000bT NICs, but I'd like to take advantage of some fault tolerance and redundancy because this server will eventually be colocated a few hundred miles away from me.

    The machine is freshly installed and my NIC configurations look like this:

    /etc/modprobe.conf
    /etc/sysconfig/network-scripts/ifcfg-eth0
    /etc/sysconfig/network-scripts/ifcfg-eth1
    So what files do I need to create and edit to get my network bonding going (I'd like to run in mode 5 or 6)? How should the files look when I'm done?
     
    Last edited: Aug 22, 2007
  2. BlahBlah

    BlahBlah New Member

    Here is what I've got so far:

    /etc/modprobe.conf
    /etc/sysconfig/network-scripts/ifcfg-bond0
    /etc/sysconfig/network-scripts/ifcfg-eth0
    /etc/sysconfig/network-scripts/ifcfg-eth1
    But... The machine is inaccessible. What am I doing wrong?
     
  3. BlahBlah

    BlahBlah New Member

    I just tried this as well, also to no avail:

    /etc/sysconfig/network-scripts/ifcfg-bond0
    I used the values originally present on eth0 from the fresh install with working networking.

    I did notice an issue with an IP conflict during a reboot. During startup, the machine was trying to bind the IP to (I assume) bond0, but it failed saying the "Another host is using that IP."

    For a simple how-to, this is starting to wear on my nerves. :(
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your logs? Are you sure that no other system is using that IP?
     
  5. BlahBlah

    BlahBlah New Member

    The only machine using this IP was this same machine, before I started messing with the bonding settings. Everything worked fine when I just had the IP set static on eth0.
     
  6. BlahBlah

    BlahBlah New Member

    Anyone have any suggestions? I still am not able to get bonding to work. :(
     
  7. falko

    falko Super Moderator ISPConfig Developer

    I don't know what's wrong.. :(
     
  8. adaughterson

    adaughterson New Member

    BlahBlah;

    Try this:

    Code:
    cat /proc/net/bonding/bond0
    What does that output?

    AD
     

Share This Page