need webmail.domain.com --> domain.com/webmail

Discussion in 'Installation/Configuration' started by ngoyette, Oct 5, 2011.

  1. ngoyette

    ngoyette New Member

    well i just made another alias sub domain , called test.quebec-gamers.com (my own domain and now using it for testing.) so i created the alias subdomain as a redirect, did not touch DNS , will see.. if this works it mean that ispconfig would create dns on its own , and those would be transparent to the administator user (me in this case) in the DNS part of ispconfig ..

    will wait to see if those change take effect until tomorow
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 3 does not create dns records for subdomains added in the sites module automatically. You have to create a dns a-record in the authoritive nameserver of the zone for the subdomain. This can be the dns server of your ispconfig server or the dns server of the provider where you ordered the domain.
     
  3. eko_taas

    eko_taas New Member

    Just to clarify my situation:
    - Both domains (example.com and xyz.dyndns-ip.com pointing to server1 (incl. subdomains).
    - redirection done on their subdomains....
    - no manual DNS-setting needed on server1, only in domain-source (domain-provider or whatever it's called....)
     
  4. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    Redirect type

    Please see page 92 in IC3 manual for doing a redirect. Watch what redirect type you're using.

    R,L is used with URL

    L is used with subdirectory folder, i.e. /webmail/

    I have used the later of the two which worked for me. Hope that helps.
     
  5. ngoyette

    ngoyette New Member

    i understand,

    so

    if i have : DNS :
    [​IMG]

    and : ALIAS :
    [​IMG]

    typing web.lburgoyne.ca should redirect me to http://mail.lburgoyne.ca/webmail right?


    but i still get:
    [​IMG]
    after 2 days... still...\



    so is there something wrong in my config??





    how can i check WHY this is not working????? because i know the config is right i checked on so many guide...
     
  6. JESUSSAVES

    JESUSSAVES New Member HowtoForge Supporter

    fix Web Aliasdomain page

    DNS is OK.
    ________________________
    What you need is to fix your rewrite rules. Instructions are on pgs 92, 99 & 101 ISPConfig-3 manual.

    On the Web Aliasdomain page use either:

    Domain is OK.
    Parent website is OK.
    Redirect Type should be: R,L
    Redirect Path should be: http://lburgoyne.ca/webmail/
    Auto-Subdomain is OK.

    or you can use this instead:

    Domain is OK.
    Parent website is OK.
    Redirect Type should be: L
    Redirect Path should be: /webmail/
    Auto-Subdomain is OK.

    ________________________________________
    Either of these two should work OK but the way you have it now looks like a problem.
     
  7. vwpete

    vwpete New Member

  8. ngoyette

    ngoyette New Member

    well all the redirect don't work ... followed poster's help , and ispconfig 3 manual..

    maybe something went wrong during install of ispconfig , i maybe made a bad choice somewhere following the guide...


    how can i check why the redirect is not being done?


    thank you.
     
  9. ngoyette

    ngoyette New Member

    when doing change for aliasdomain for website , it make changes in the file 100-domain.vhost inside the /etc/apache2/sites-enable/ right?
    (same thing in sites-available)

    what if in this file i can see

    ServerName lburgoyne.ca
    ServerAlias www.lburgoyne.ca
    ServerAlias web.lburgoyne.ca
    ServerAlias webmail.lburgoyne.ca


    but i do not see any redirection config ? that would not be normal yes?

    what can i do to remedies to this problem?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ISPConfig version do you use and if its 3.0.4, when do you download it? The redirect config was broken in 3.0.4 beta and is fixed in 3.0.4 final.
     
  11. ngoyette

    ngoyette New Member

    oh god... so many hours ... spent ..... that was probably my problem ... since now i upgraded to the latest ISPConfig 3.0.4.1 and all my redirect suddenly started working ..

    ....
     
  12. QuetzalFirst

    QuetzalFirst Member HowtoForge Supporter

    Hi
    I have an issue with redirection when roundcubemail is not on same server than web site server. The rewrite condition is on the conf of site (on the web server) not on the http server (on the mail server) which serve the roundcubemail.

    So i think i will put the roundcube mail on the webserver (for simplicity).

    I try to put :
    RewriteCond %{REQUEST_URI} !^/webmail/
    RewriteRule ^/(.*)$ /webmail/$1 [R,L]
    on the httpd.conf of mail server (this server is only for phpmyadmin and roundcube).
    No success... I think it's not the good rewrite rule...
    I need that all webmail.anyDomain or mail.AnyDomain or better all request to *.MailServer_IP redirect to
    *RequestUrl/webmail/
     
    Last edited: May 7, 2015

Share This Page