Need urgent help regarding Apache2 With mod_fcgid And PHP5 On Debian Lenny

Discussion in 'Installation/Configuration' started by latheesan, Dec 23, 2010.

  1. latheesan

    latheesan New Member

    Need help regarding Apache2 With mod_fcgid And PHP5 On Debian Lenny


    I followed this tutorial to setup web server with php running FastCGI on my debian vps server.

    After finishing the tutorial, it appears i can set it up correct as i can view the PHP Info just like mentioned on the tutorial.

    You can see it here :

    I hve been developing a script on my local server environment (Windows + XAMPP) and when I uploaded the finished script to my server, I am seeing a blank page, absolutely no error:

    I checked the apache2 error log and these are the last few entries on it:

    Any idea why I am getting a blank page? How can i diagnose the problem and fix it?

    Thanks for any help you can provide me.

    Regards, Latheesan.
    Last edited: Dec 23, 2010
  2. latheesan

    latheesan New Member


    I think I asked for help too soon. Since phpinfo() was working, I should have known the setup was fine.

    While waiting for a reply, I engaged in a tedious debugging session by putting a exit('Here : '. __LINE__); after every line of code on my index.php to see where the script was halting.

    I noticed that, the script stops executing after i call mysql_connect() function, which suggests my server did not have php5-mysql installed.

    So, I executed apt-get install php5-mysql and /etc/init.d/apache2 restart as root and visited the script again and everything was fine.

    Although one thing still a mystery, why did php not raise any error regarding missing library php5-mysql, and instead it just displayed a empty page?

    I had error_reporting set to E_ALL | E_STRICT =/

Share This Page