Need to use the SMTP from my home PC

Discussion in 'Server Operation' started by sspitfire, Nov 4, 2011.

  1. sspitfire

    sspitfire New Member

    Hi. I have a VPS with Ubuntu LAMP 10.4; Postfix; courier; IMAP I can send and receive emails on it, but when I try to use it w/ Thunderbird or Outlook from my home PC I get:
    Code:
    554 5.7.1 : Relay access denied 
    Also when I try to telnet from my windows PC i get
    Code:
     Could not open connection to the host on port 23. Connect failed 
    Whats the proper settings of Postfix to achive this? and what port to use? I guess its 110 for pop3 ?
     
    Last edited: Nov 4, 2011
  2. sspitfire

    sspitfire New Member

    bump... anyone?
     
  3. edge

    edge Active Member Moderator HowtoForge Supporter

    Did you enable "My outgoing server (SMPT) requires authentication", and set it to "Use same settings as my incoming mail server"?
     
  4. sspitfire

    sspitfire New Member

    how would I do it? Currently it's not an open relay if thats your question.
     
  5. kevin.cousins

    kevin.cousins New Member

    The proper port for SMTP and Telnet is port 25.

    In Outlook: Change E-mail Account ===> More Settings ... ===> Outgoing Server ===> My outgoing server (SMTP) requires authentication ===> Use same settings as my incoming server.
     
  6. sspitfire

    sspitfire New Member

    I did it and I get error: The mail server responded: 5.7.1 Relay access denied. Cannot deliver to xxx@gmail.com Please check your recepient. I think the problem is in the postfix configuration.
     
  7. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  8. sspitfire

    sspitfire New Member

    The IP is clean. The problem is in the postfix config. can some1 tell me the proper config pls so I can use my server as a relay and send from my home PC w/ Thunderbird or Outlook. With Thunderbird I can connect to the server and see the messages in the inbox and read them, but when I try to send mail I get the above mentioned error
     
    Last edited: Nov 5, 2011
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you enable "Server requires authentication" in your email client?

    What's in your main.cf?

    Where is the server hosted? Does it have a static or dynamic IP?
     
  10. pattone

    pattone New Member

    How do you setup your smtp relay?? you could take a look at http://www.howtoforge.com/postfix_relaying_through_another_mailserver

    Do you know if your ISP don't block your port 25 (many ISPs does) you could try smtp submission to use port 587 instead, just edit master.cf of postfix configuration and uncomment th line that says

    Code:
    submission inet n       -       -       -       -       smtpd
    in
     
  11. mmidgett

    mmidgett Member

    Or use SSL port 465. Just about every isp blocks port 25 unless you have a business account.
     
  12. clttech

    clttech New Member HowtoForge Supporter

    If I un-comment this line for port 587 to work, will port 25 still work? We use an inbound filtering company and they send to us on port 25. So our firewall rules only allow from that company on port 25. I need to be able to have our mobile users to be able to send and receive as well. So if I un-comment that line, will I accept on both port 25 and 587?
     
  13. mmidgett

    mmidgett Member

    Yes it will still work. Your "filtering company" who are they?
     
  14. clttech

    clttech New Member HowtoForge Supporter

    Securence is the service we use.
     
  15. skoena

    skoena Member

    Uncommented
    Mail is still not send.
    Changed squirrelmail setup as well for use with port 587 but email is not sent/arrived.
     
  16. clttech

    clttech New Member HowtoForge Supporter

    I un-commented that line and all is working well.

    Not sure what you have going on.
     
  17. skoena

    skoena Member

    I moved the server from a datacenter to my home.
    Port 25 is blocked for sending mail so I would like my server to mail using port 587.

    Should I use a relay server like gmail? Or can my server send mail from port 587?
     
  18. edge

    edge Active Member Moderator HowtoForge Supporter

    Ziggo.nl is blocking a lot of ports.

    I think that the easiest thing to do would be to use ziggo's outgoing mailserver. (relayhost = smtp.ziggo.nl)
    Some more usable info (in Dutch) here: http://e2b.org/5q
     
    Last edited: Feb 22, 2013
  19. skoena

    skoena Member

    Edge, tnx for your reply.

    When I use the relayhost of Ziggo is there a maximum of emails being sent?
    I could use the relay host of Gmail but the thing I have seen is that google replaces the senders email adres by my email address :-(
     
  20. edge

    edge Active Member Moderator HowtoForge Supporter

    I'm not with Ziggo, but I'm sure that there is a cap on the amount of emails per hour.

    Other problem is that Ziggo's dynamic IP block is almost always blacklisted, causing other email servers to see any email from Ziggo as spam.

    I've never used gmail as relay host so I can not help you with the gmail problem.
     

Share This Page