need to reconfigure the locales

Discussion in 'Installation/Configuration' started by Appie Thrasher, Nov 21, 2008.

  1. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    Hi all,

    I am trying setting up an site with Gallery2 in it, in the Dutch language.
    I have my server installed the perfect way Ubuntu 8.04 (Uk).

    If I read it correctly on the gallery2 site faq
    I must set up gettext somehow in php. I have searched my php.ini but can't find anything to enable gettext. I have also found a thread here that says it can't be installed in ISPConfig
    http://www.howtoforge.com/forums/showpost.php?p=31243&postcount=4

    Must I realy install all again in the Dutch language so start from scratch again? I hope not.

    TIA

    Hope the post is in the right section btw
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    locale -a
    ?

    This refers to the PHP that comes with ISPConfig, but not your main PHP installation. gettext is probably already enabled.
     
  3. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    The output is only the Uk and Us language I have done that already as mentioned in the Gallery thread. I guess this is normal because I installed an Uk Ubuntu version. So my simple thought is to put also the nl_NL? language somewhere in there, but I don't know how.
    apt-get???

    Code:
    root@server1:~# locale -a
    C
    en_GB.utf8
    en_US.utf8
    POSIX
    root@server1:~#
    
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    try:

    dpkg-reconfigure locales
     
  5. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    Code:
    root@server1:~# dpkg-reconfigure locales
    Generating locales...
      en_GB.UTF-8... up-to-date
      en_US.UTF-8... up-to-date
    Generation complete.
    root@server1:~#
    
    Output is that all is up to date. Of course just installed everything. But still no nl_NL.
    I think if I install the dutch language somehow everything is working fine. Or is the gettext not enabled????
     
  6. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    Think I find my own answer I did this

    Code:
    apt-get install language-pack-nl language-support-nl
    Than this

    Code:
    dpkg-reconfigure locales
    Output

    Code:
    root@server1:~# dpkg-reconfigure locales
    Generating locales...
      en_GB.UTF-8... up-to-date
      en_US.UTF-8... up-to-date
      nl_BE.UTF-8... up-to-date
      nl_NL.UTF-8... up-to-date
    Generation complete.
    root@server1:~#
    
    AHA the Dutch are arrived!!

    Going to check my Galley2 now.

    Thanks and will let you guys know of this was right..

    That did the trick for me all is working fine.
     
    Last edited: Jan 1, 2009
  7. raymonvdm

    raymonvdm New Member

    This did NOT solve my squirrelmail problem. (only english is working)
     
  8. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    Okee will try to help you but I am petty new to this my self so if I can't forgive me.

    What's the output of
    Code:
    locale -a
    ?
     
  9. raymonvdm

    raymonvdm New Member

    I have found a solution

    http://ubuntuforums.org/showthread.php?t=208145


    vim /var/lib/locales/supported.d/local

    nl_NL.ISO-8859-1 ISO-8859-1 <-- add these rule
    en_US.UTF-8 UTF-8


    dpkg-reconfigure locales

    And now dutch is working. I need to do this for other languages
     

Share This Page