Need to find where the admin port is set

Discussion in 'Installation/Configuration' started by User4572, Aug 13, 2020.

  1. User4572

    User4572 New Member

    I screwed up, wasn't watching when I upgraded.
    When the upgrade asked me for the admin port I wasn't paying attention and had too many ssh screens up. I typed in reboot because I thought I was rebooting that machine.. now I cannot access the admin page.. Which file do I need to modify to bring it back to the default port?
     
  2. ahrasis

    ahrasis Well-Known Member

    Default is 8080 and it is normally in the ispconfig.vhost file.
     
  3. nhybgtvfr

    nhybgtvfr Active Member

    or just re-run the upgrade, and specify the correct port this time.
    i'm not sure if the ispconfig.vhost is the only file (or db field) affected by what you enter here, it probably is, but re-running the upgrade would avoid any possibility of missing a change somewhere.
     
    Th0m likes this.
  4. SSK

    SSK Member

    I have a similar issue. Setting up permanent redirect in the SSL tab for the landing page connecting the control panel interface resulted in the 404 error. I checked the ISP conf file and also other related files. Nothing appears to be affected. It just goes to the default index page rather than the ISPConfig interface login page. Any suggestion to fix this issue would be appreciated.
     
  5. User4572

    User4572 New Member

    I tried re-running, system wont let me.
     
  6. User4572

    User4572 New Member

    ok, I found it. I'm rebooting now
     
    Last edited: Aug 14, 2020
  7. SSK

    SSK Member

    Depending on the type of server you have, the host file should be under /etc/servertype/... - if that is what you were asking for?
     
  8. ahrasis

    ahrasis Well-Known Member

    No need to reboot all the time. You only need to test your web server if all of its vhost is ok and then restart it. For example in nginx web server you may want to run "nginx -t; service nginx restart".
     
  9. nhybgtvfr

    nhybgtvfr Active Member

    you can't just re-do ispconfig_update.sh, you'd need to

    Code:
    cd /tmp
    wget http://www.ispconfig.org/downloads/ISPConfig-3.1.15p3.tar.gz
    tar xvfz ISPConfig-3.1.15.p3.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    
     
  10. SSK

    SSK Member

    In my case, as shared before, the site and the domains inside the server are all fully functional. Only the landing page that is connected to the ISP Interface is not functional. For that matter, even two subdomains attached to the primary domain is functional.

    This happened recently after an upgrade to 20. I had issues with the cloud drives after the switch, which was resolved, as shared in another set of posts of mine. This one is still not resolved. I believe that it is a simple config issue, but could not zero in yet.

    Basically, the landing site gets redirected to the default index page of the domain rather than to the default interface page. Any thoughts on how to resolve it.
     
  11. nhybgtvfr

    nhybgtvfr Active Member

    @SSK that appears to be a completely different issue to the OP's post, where he put the wrong string in for the port number during the update process.
    the obvious starting point for you would be to remove the permanent redirect you put in, should be in /etc/apache2/sites-available/ispconfig.vhost or /etc/apache2/sites-available/<domain.tld>.vhost, or wherever nginx stores it's vhosts.
     
    SSK likes this.
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    @nhybgtvfr posted in #9 what you must do to fix this. Follow his instructions and enter the correct admin port this time, which is 8080, do not enter something like 443 or 80 there as these ports are already in use and you will just break your system by entering a non-dedicated port here.

    @SSK: you said something about upgrading to 20, I hope you don't mean Ubuntu 20.04, as that's not supported by ISPConfig yet, you would have to use the development version of ISPConfig (stable-3.1 branch from GIT) if you would want to use ISPConfig on Ubuntu 20.04. And please do not hijack other threads as your problem does not seem to be related to the one of the original poster.
     
  13. SSK

    SSK Member

    @nhybgtvfr: Thanks. It is apache, and I already looked at both the vhost files in vain. Maybe, not looking at the right location. Can you shed some more light to address this one?
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    He posted the commands that need to be run in #9 in case you entered a wrong port as the first poster did. Just be aware that ISPConfig
    3.1.15p3 is not compatible with ubuntu 20.04, so don't use that version on Ubuntu 20.04, instead you must use the 3.1dev version on an ubuntu 20.04 system.
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    To run an update with 3.1dev, just run:

    ispconfig_update.sh

    command on the shell and select git-stable as update source.
     
  16. SSK

    SSK Member

    Clarification:

    1. Version Installed: stable-3.1 - at that time - it was 18.0.4 - switched from Virtual/Webmin
    2. Upgraded to 20.0.04 - a month or so ago
    3. ISPConfig interface was fully functional even after the upgrade
    4. Setting permanent redirect from http to https (http was taking to the default index.html page and the secure site taking to the login page) affected the interface
    5. Otherwise, the entire system is fully functional even now including two subdomains under the parent domain

    Update.sh file that is placed under /usr/local/bin - If I run that script, would it automatically update the vhost file and address this issue? Do I need to be concerned about anything before the update?

    With regard to the manual, may I know whether this would be a good one - we have been referring to -
    http://www.ispconfig.org/downloads/manual_en/manual_full_en.pdf
     
    Last edited: Aug 14, 2020
  17. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes

    If you manually altered the ISPConfig vhost file, then yes. if you did not manually alter it, then no. As there is no setting to force HTTP to https for the ispconfig vhost, you must either have altered it manually or your issue is not related to this whole thread. If you set this redirect in another website and it caused that problem, then temporarily disable that other website by removing its vhost file symlinks in the apache sites-enabled directory and restart apache to gain back access to the ispconfig UI. But redirects of ISPConfig sites can not cause this, unless you manually altered the ispconfig vhost file by not using a dedicated port for the ISPConfig UI.
     
  18. SSK

    SSK Member

    @Till: Thanks.
    Here is what led to the issue:
    1. Change was made inside the portal
    2. Clicked on the Sites section, which took me to the list of sites
    3. There, I clicked on the site of interest, the primary landing site, as I usually do to manage my sites - I have set many things over there such as, SSL, htpasswd, user management etc
    4. Right there, I clicked on the SSL tab
    5. In the SSL section, I clicked on the box for a permanent redirect from http to https

    Since then, I have been having this issue.
     
  19. till

    till Super Moderator Staff Member ISPConfig Developer

    So your issue is not related to this thread or the ispconfig vhost, that's why you received wrong or confusing answers. Next time, don't post in other user's threads if your problem is not exactly the same than the problem of the original poster. To fix your problem:

    1) Disable the symlink for that website in the apache sites-enabled directory and restart apache.
    2) Login to ispconfig and disable the HTTP to https redirect that caused the problem. Also check redirects of that website in general, maybe you added a redirect for wildcard subdomains or something similar in conjunction which using one of the subdomains that you redirected by this for your ispconfig vhost.
    3) Now enable SSL for that specific website and test that the site really works over SSL before you enable a SSL redirect for it.

    Such an issue can only occur when you manually change the ispconfig port, there is a good reason why the isp config port is 8080 by default and not 443 as this ensures that you can always access ispconfig even if you do a misconfiguration in a website to redirect traffic that is intended to end up for the ISPConfig Ui to another site.
     
  20. SSK

    SSK Member

    ================================================================================
    Thanks. First of, I am not certain whether I am the only one seeing this issue. When I click on Reply thread, I don't see an edit box to reply right away. It takes some time for the reply option to show up. It has led me to re-post the previously replied post again a couple of times, and then ended up deleting the post.
    ================================================================================
    Coming back to the issue, thanks for clarifying.
    This is the symlink that I have for the landing url in the sites-enabled directory,
    100-comedaddymummy.com.vhost -> /etc/apache2/sites-available/comedaddymummy.com.vhost

    I believe that rm should be able to remove the link. Is this the one that I need to remove? If yes, may I know the exact way to do it? Having spent time on this one for some time now, and after initiating a couple of other threads (I believe someone asked me to change the location of the initiated thread) without much participation, I finally see some light at the end of the tunnel to address this issue. So, I might as well make both of our times valuable by being direct in addressing this issue.

    I guess then rm 100-comedaddymummy.com.vhost should rm the symlink - right?

    Once I do this, would I get the Config panel working. How can I access the config panel?

    With regard to 443 vs 8080, yes, we are using 443. Maybe, when we update next time, we will change the port to 8080.
    =============================================================================================

    Please note that the issue is the following:
    404 error for this domain: https://www.comedaddymummy.com/login - which was functioning before

    I am sharing again to be certain that we are on the same page.

    ==============================================================================================
     
    Last edited: Aug 14, 2020

Share This Page