Need to compile with G++ 3.X.

Discussion in 'Installation/Configuration' started by edge, Nov 1, 2008.

  1. edge

    edge HowtoForge Supporter

    Hi all,

    I need to compile something with g++ 3.X. (and not the last g++ 4.X.)
    For testing I created a virtual host, with a clean install of Dbian Etch.
    I installed g++ 3.x with "apt-get install g++-3.4", and it looks like this worked fine.
    However when I do a ./configure I get the following error:
    So.. It looks like I'm missing gcc.
    apt-get install gcc-3.4 looks fine, and it installs fine.

    Again when I do a ./configure I get the same error as above.
    The onlyway I get even close to installing is when I do an "apt-get install build-essential". but this will install ++ 4.X, and will break the make.

    Any suggestion on what I could try to get this installed?
     
  2. falko

    falko Super Moderator

    Maybe you can try to create a symlink from g++ 4.x to g++ 3.x. However, I don't know if it works.
     
  3. edge

    edge HowtoForge Supporter

    I found a beta version of the program that I needed to compile.
    The beta version did wotk with g++4, and it looks like the beta version is working fine (for now)

    Thank you for your info, but it was not needed, and did not test it!
     

Share This Page