Need some help with ispconfig errors

Discussion in 'Installation/Configuration' started by kadi, Dec 20, 2007.

  1. kadi

    kadi New Member

    hello
    I installed debian etch and followed the perfect setup, then installed ispconfig 2.2.18.
    I have some issues with ispconfig:
    I deleted ARecord & CNAME because i was having problem with dns is not
    resolving to the domain name and still, when i try to add them again i got
    an error on Arecord after i try to save " There is already a CNAME Record entry for this host in this zone." then i tried to add CNAME and got this : "There is already ARecord entry for this host in this zone."
    I checked all recyclebins nothing in it.
    I read on a post here you can delete it from the database table dns_a but i don't know how to
    find it or where it is .
    Another issue is when i empty the recycle bin and try to check it after long
    time it says that it still updating the system please wait a while and try again.
    The last issue is: proftpd server was working fine and today i was trying to
    check the servers and it says FTP server offline , i try to run it from the shell
    and said failed, is this may be because i changed the IP ?
    Thanks any help will be appreciated.
    :)
     
    Last edited: Dec 20, 2007
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please empty the recycle bin in the dns manager.

    To your ftp problem, please configure proftpd to listen also on the IP 127.0.0.1
     
  3. kadi

    kadi New Member

    Thanks till for your help

    hello till
    thanks for your response.
    I tried to empty the recyclebin on dns, like i mensioned above and it gives me
    the same error, so i found dns_a and took it out from their (phpmyadmin ispconfigdb table dns_a) even doing that did not stop the same errors.
    concerning proftpd the listen to IP 127.0.0.1 how to do that ? i mean what to write ? , what is weird is last time that happen i installed it and take it out like 10 times untill it works, and my host file which it could be the reason is correct with server name and IP.
    As a final solution i thought to uninstall ispconfig and reinstall after installing
    proftpd first, if this will solve the problem.
    another simple question i rather to ask it here instead of posting
    a new one:
    myserver is just for me no resellers no clients no customers, so
    where will be the best place to put the sites ? like under admin, sites ?
    + i don't see the file manager folder anywhere ? or i have to create
    the folder file manager ?
    Thanks very much for your help.
     
    Last edited: Dec 20, 2007
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    At least you must create one customer (this can be yourself); you can create it under admin and then place the web sites in the Sites folder.
     
  5. kadi

    kadi New Member

    Thanks

    hello again
    Thanks for your response again.
    OK i have a question :
    in the ISPConfig DNS manager under the tab : Domain & ARecord & CNAME
    which IP address should the one from the router:192.168.x.x or the system
    IP 97.312.XX.XX ?
    also I don't see File Manager folder ?
    Thanks again
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    For DNS records use your router's public IP address.
     
  7. kadi

    kadi New Member

    Thanks for your reply

    hello
    Thanks for your reply.
    I got tired of proftpd trying to install it so many time and it didn't work, so
    i installed vsftpd instead, and i follow the setup instructions to make it secure
    with mysql, now i created a /home/vsftpd/user like the instructions said and was able to upload files in ispconfig , my question is :
    when i upload a new index ,it didn't show because ispconfig set the directory
    different , where am i suppose to put my sites files on the sever in which
    directory? if i put it like what ispconfig.conf said /var/www/web1/web
    i can't upload it because vsftpd use /home/vsftpd/username/site ?
    how can i slove this problem ?
    Thanks again very much:)
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    The vsftpd with MySQL setup is incompatible with ISPConfig because ISPConfig uses system users, not virtual users.
     
  9. kadi

    kadi New Member

    Thanks and happy holidays

    hello
    thanks and happy holidays , now after i made this mistake, what should i do
    to correct it ? like remove it then reinstall ? and how to remove it from mysql?
    i need some instructions to clean the mess , also please if you have any link
    for instructions on how to configure it with ispconfig.
    Thanks again and happy holidays.:)
     
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    FTP does not have to be configured to work with ISPConfig, it works right out of the box with the configurtaion that comes with the linux distribution.

    I recommend that you uninstall FTP including all config files and then reinstall it as described in the perfect setup guide for your linux distribution.
     
  11. kadi

    kadi New Member

    Thanks till

    hello Till
    Thanks for your reply.
    I did like you said and thanks it is working fine now.
    I just have another question :
    to make sure of my Ispconfig setup:
    Under Managment/ settings : i put the router private address 192 168.XX.XX
    Under ISP Manager : I put the same 192.168.XX.XX
    Under DNS Manager/Domain : I put the public ip : 97.81.XX.XX
    Under DNS Manager/ARecord : The same public ip : 97.81.XX.XX
    Is that setup right ?
    I am asking because i can get to the site from my server but not from outside
    (web), also if i write the domain name from the web: www.mydomain.com:81 i don't get the Ispconfig login but when i use the private IP 192.XX.XX.XX:81 i can get the login for the ispconfig, or if i write only
    the 192.XX.XX.XX i get SharedIP page.
    so i don't understand what is wrong or missing.
    Thanks again and happy holidays.:)
     
    Last edited: Dec 25, 2007
  12. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Yes, if 192.168.XX.XX is the IP that you see in the output of
    Code:
    ifconfig
    Please make sure that your router forwards the ports 80 and 81 to your ISPConfig server.
     
  13. kadi

    kadi New Member

    hello and thanks again

    hello again and i hope i am not bothering you too much.
    My router is FM114P netgear and to do port forwarding i have to use
    Rules, and services :
    1- there is Inbound & Outbound i don't know which one to choose?
    2- start port & end port i need to know which ones?
    3- in Reserved table : i setup static IP 192.168.XX.XX
    ===========================================
    another simple question no need to make another post for it:
    My server when start always with resolution 640X480 and it is set
    to 1024X768 , and when it starts with 640X480 it does not give me
    any choice to adjust it, i have to restart to get the real resoloution
    1024X768 what could be the reason for that ?
    again thanks very much and happy holidays.:)
     
  14. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Inbound.

    For HTTP: start port: 80; end port: 80 as well;
    for ISPConfig: start port 81; end port: 81.
    Do you run a desktop on your server? This can cause problems security- and performance-wise... :eek:
     

Share This Page