Need little help

Discussion in 'Installation/Configuration' started by valter, Dec 5, 2006.

  1. valter

    valter New Member

    I'm totally new to Linux, so please take it easy on me :)

    I have a linux box (FC6) behind the router, with the local IP address 192.168.0.10 that is NAT-ed through the router to the Internet and is presented as 212.212.212.212 (example). I also have a domain domain.net registered on the Internet Register. Now let's go to the questions :)

    1. In the ISPConfig setup, one of the very last questions was IP address, and I've typed in my global IP address (212.212.212.212), is this correct?

    The host is called test and the domain is domain.net, so ISPConfig is accessible via https://test.domain.net:81 I've created new client AABBCC with their internet domain www.aabbcc.com (example)

    2. Now, if I look under DNS under the client AABBCC, I can see that Nameserver 1 and Nameserver 2 are test.domain.net is this correct?

    3. On the Records tab I HAVE The following:

    For the A records
    Code:
      IP-Adresse  	             Hostname 
      212.212.212.212  	  www 
    
    and for the MX records
    Code:
      Mailserver  	             Hostname 
      test.domain.net  	  www 
    
    is this correct?

    4. The domain www.aabbcc.com is registered on the Internet Register. What should I use as my namserver address. ns1.domain.net and ns2.domain.net (have made these in advance) or test.domain.net (that is the address of the box with ISPConfig)?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) yes
    2) yes, but you may change it to ns1.domain.net and ns2.domain.net, make sure that ns1.domain.net and ns2.domain.net exist in DNS and point to the IP 212.212.212.212.
    3) Please empty the hostname field in the MX settings of the domain.
    4) That depends on the decision you made in 2.
     
  3. valter

    valter New Member

    Thank you very much, I got that right. Now, however I have another problem. I've made another website 123.net and I can see that ISPConfig has created vhost, but if I try to opet the aforementioned domain in the browser all I got is default apache webpage from the default vhost. Then I have to edit vhost via webmin, and change Server to ANY and restart apache in order to work. Beside if I want to use SSL I've got an error while restarting apache that SSL port is overlaping and that default one has a priority. Any idea what am I missing out? Thanks :)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You selected the wrong IP address for the website in ISPConfig.

    By the way, do not use webmin together with ISPConfig as this will result in errors and inconsistent config files.
     
  5. valter

    valter New Member

    :) well when creating new site, I've got an option to chose either the local IP address 192.168.0.10 or the global one 212.212.212.212, and I've select the global one! I hope this is what I should select!?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ifconfig
    ? You must select the IP address that you see in the output.
     
  7. valter

    valter New Member

    Code:
    [[email protected] ~]# ifconfig
    eth0    Link encap:Ethernet  HWaddr 00:0C:F1:8A:8E:57
              inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::20c:f1ff:fe8a:8e57/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:8395 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2485 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:3182293 (3.0 MiB)  TX bytes:214706 (209.6 KiB)
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:4433 errors:0 dropped:0 overruns:0 frame:0
              TX packets:4433 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:4848873 (4.6 MiB)  TX bytes:4848873 (4.6 MiB)
    
    peth0   Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
              inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
              UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
              RX packets:8487 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2622 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:3201366 (3.0 MiB)  TX bytes:229347 (223.9 KiB)
    
    vif0.0   Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
              inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
              UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
              RX packets:2487 errors:0 dropped:0 overruns:0 frame:0
              TX packets:8395 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:215030 (209.9 KiB)  TX bytes:3182293 (3.0 MiB)
    
    xenbr0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
              inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
              UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
              RX packets:5229 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:382868 (373.8 KiB)  TX bytes:0 (0.0 b)
    
    [[email protected] ~]#
    
    ifconfig shows in eth0 IP 192.168.0.10, but if I use that IP will that IP be used when DNS records are created? Just to mention again, during the ISPConfig, when I was asked for the IP, I've entered the global IP 212.212.212.212 and not local 192.168.0.10. :)

    Take a look at the image :)

    [​IMG]
     
    Last edited: Dec 6, 2006
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You must use the internal IP for the website and the external IP address for the DNS-Records in the DNS-Manager.
     
  9. valter

    valter New Member

    I'll give it a try :) thanks :)
     

Share This Page