need help setting up a mail server

Discussion in 'Server Operation' started by paulley, Feb 18, 2006.

  1. paulley

    paulley New Member

    hi

    i have setup the mx dns records but how do i create accounts and login details etc for email@domain.com address


    thanks
     
  2. till

    till Super Moderator

    How did you configure your server, have you used one of the perfect setup howtos? Have you installed ISPConfig?
     
  3. paulley

    paulley New Member

    i have manual configure it by opening the files and entering the information and then saving them. I have not using ispconfig or any of your how to's they seem a bit difficult. do i have to use a cp of some sort to setup it up or can i just do it manualy though the files to create the account, because to recevice the email i am just using a email client with the login detail and the the mail.example.com which i have set the dns records to point to a ip and also the mx records for the mail server address.
     
    Last edited: Feb 19, 2006
  4. falko

    falko Super Moderator

  5. paulley

    paulley New Member

    i have done what say but it aint working theres no virtusertable and local-host-user in the postfix folder:mad: oh also when i restart postfix its say shutting down failed , but starting ok this is on fedora 4
     
    Last edited: Feb 19, 2006
  6. falko

    falko Super Moderator

    You must create these files.
     
  7. paulley

    paulley New Member

    do you change any for the code whats in the quote boxes or just type all the code as it is there.


    thanks
     
  8. falko

    falko Super Moderator

  9. paulley

    paulley New Member

    well i have done what it say but the problem i have is , i enter the mail server address as mail.domain.com but when connecting to say time out and the ip. I have set the domain:

    www IN CNAME domain.com
    domain.com IN A ip
    mail IN CNAME domain.com
    domain.com IN MX 10 mail.domain.com

    i have no firewall on as yet and the port are right thought router, but cant understand why it aint connecting

    oh last thing when i go to mail.doamin.com in the browser it display the stanard default start page when there no page in the root dir so it getting though ok.


    thanks
     
  10. paulley

    paulley New Member

    sorry my bad port was wrong, but it saying that the connection is refused:mad:


    just done telnet mail.domain.com and to cannot connect to the host:s
     
    Last edited: Feb 20, 2006
  11. falko

    falko Super Moderator

    Do you have a firewall on the server?
    Is inet_interfaces set to all in /etc/postfix/main.cf?
     

Share This Page