Need Help - email via ISP & Dynamic DNS

Discussion in 'Installation/Configuration' started by jwan, Oct 11, 2006.

  1. jwan

    jwan New Member

    Hi all,

    I had been using windows-based Mdaemon for sometime and now migrating to linux (ubuntu 6.06). I had setup ISPConfig, but dont know where or how to make postfix send mail out via my ISP SMTP. My ISP requires SMTP-Authentication for using their SMTP as relay. Need help on where to configure??

    Also, I'm using to dynamically set my ip. Is there any solution to update from linux in a regular basis? I've read ddclient, but do idea how to use

  2. falko

    falko Super Moderator ISPConfig Developer

    Have a look here:

    Try this:
    apt-get install ddclient
    Edit /etc/ddclient.conf and restart ddclient:
    /etc/init.d/ddclient restart
  3. jwan

    jwan New Member

    More question for DDClient

    Hi thanks for the link, it does work!!!

    For DDClient, I had downloaded, configure /etc/ddclient/ddclient.conf to work with my zoneedit setting. However, I would like to know how to make DDClient loaded up automatically every hardware reboot? also, how to make ddclient update ip address say every 30mins?

  4. falko

    falko Super Moderator ISPConfig Developer

    This happens automatically if you installed it like I wrote.

    It updates the IP address whenever it changes. That should be sufficient. :)
  5. anakein

    anakein New Member

    relayhost has been esay but...

    thanks for easy explanation for relayhost, and now.

    Now, I want catch mail from external mail server, and put into maildir user.

    for example, local user into domain has email [email protected] and this user want to catch email from [email protected] into [email protected].

    is this possible?

    thanks for all, and great work
  6. jwan

    jwan New Member

    follow up

    First of all, I thought I had everything setup until I noticed something wrong, I can't send email to address of my same domain or even to itself. Eg. [email protected] can't send to either [email protected] or [email protected]. All tries to get through the relayhost.

    How to make it in such a way that all local mails (assuming hosting different domain) will not go out via the relayhost.

    Secondly, how to make POP3 to login using [email protected] instead of web1_user? also make SMTP using also [email protected]?

    Thirdly, where can email users change their password? I had installed both Squirrelmail and UebiMiau, but none has ability to change password.

    Lastly, how come when I created a new email user and setup user real name, and then goes to either Squirrelmail and UebiMiau, the user name and email address are wrong??? i still have to reencode them in both Squirrelmail and UebiMiau to make it work.

  7. falko

    falko Super Moderator ISPConfig Developer

    Please open a new thread for this, otherwise this one will become confusing.
  8. falko

    falko Super Moderator ISPConfig Developer

    Make sure that is listed in /etc/postfix/local-host-names.

    This is not possible with ISPConfig because ISPConfig sets up system users, not virtual users.

    You must enable Mailuser for the web site in ISPConfig, and then your users can log in on http(s):// and change their passwords there.

    That's normal. You also have to configure the email address and name in a normal email client like Thunderbird or Outlook. This has nothing to do with ISPConfig.
  9. jwan

    jwan New Member

    yes its listed, and had postix restarted already. had even reboot the server and still same. Question, what should be the correct reply-to entry??? [email protected] or [email protected]?


    Got it!

  10. falko

    falko Super Moderator ISPConfig Developer

    Make sure that is listed there, not or anything else, it must be

    If [email protected] is listed in /etc/postfix/virtusertable and is pointing to web1_user, then both will work.
  11. jwan

    jwan New Member

    sending via relayhost

    Problem solved, but not until I reformat and reinstall the whole thing from scratch. After the 2nd installation, I ended up having 2 problems: (a) can't send to local address (b) all incoming mails goes out again via relayhost.

    Its really very difficult to trace problem, but fortunately, I tried checking using hostname -f and found out that the result is wrong. Somewhere somehow the /etc/hosts was altered.

    Fixing it fixes the whole problem. thanks! Although my installation is working. I still have lots of questions to ask but these will be in another thread.


Share This Page