need help!!! can't reach websites but locally (using router)

Discussion in 'Server Operation' started by razvan_vlad, May 23, 2007.

  1. razvan_vlad

    razvan_vlad New Member

    hello guys, i really need some hlep.. because i gotta get my server configured before i leave the country for 2 months.
    I can't get my websites to work but locally..
    below i wrote my settings:
    ok.. so... using ISPConfig with a router i have made those settings:
    the server's ip is
    the router (getway) is
    the modem's ip (from ISP) is
    under ISPConfig - Server - Settings i have the server's ip address ( ; and under DNS i have provided the Default NS1 with and Default NS2 with

    now.. i bought a domain.. let's say.. and on their website , i made it to point towards my modem's ip (

    on my router, i forwarded port 80 towards my server's ip ( ( this ip is within the range of router's DHCP)

    then.. creating a new website with ISPConfig, called , i have choosen it's ip , the same with the server's ip.
    then.. under DNS Manager:
    "Domain section:" the website's Domain(SOA) is and IP Address is the address of my modem (the one i had specified when i bought the domain)
    "Options section" Nameserver1 is the primary name server from the website i bought the domain .. and Nameserver2 is the 2nd one from that website.

    do those settings seem oke ?? i really need help with this.

    and just for the curiosity.. on fedora 6 .. when i go to System - Administration - Network .. the eth0 DNSes .. are the DNSes provided from my ISP (the ones that show up on the routher) .
    is this correct??

    PLEASE PLEASE help me
  2. falko

    falko Super Moderator ISPConfig Developer

    You should use an IP address that's outside the DHCP range, or you might get conflicting IP addresses.

    What IP?

    From what you told above, your registrar's nameservers are responsible for your domain, so there's no need to create DNS records for it on your own server.

    If you mean the nameservers from /etc/resolv.conf - yes.

    If you can't reach your web site, it's possible that your router doesn't support loopbacks.
    Can you try to access it from outside your network? Does it work then?
  3. razvan_vlad

    razvan_vlad New Member

    hey Falko, thanks for the reply ..

    yes..i mean.. websites created in ISPConfig(under ISP Manager) have the server's ip

    so.. you mean, when i create a website under ISPConfig, i am not supposed to check "Create DNS" for the website? so.. all i do is.. when i buy a domain online.. i point it towards my external ip (modem ip's from my ISP) , then forward port 80 on the router (it's a netgear router) towards the server's ip address , then.. ISPConfig's settings.. under the DNS section.. where i have to specify the "Default NS1" and "Default NS2" should i put the same DNSes as from my ISP? or just give random dns names .. which will represent my server's dns?

    yes.. the router does work if im trying to access it outside my network..
    and im quite not sure right now.. but what i mean.. i used the GUI Network interface in fedora.. ( i went to the toolbar menu, .. and under Administration i have Network.. and it pops up the gui for network. then.. i selected the eth0 and press DNS and it's asking me for the "primary dns" and "secondary dns". so i guess those are the dns'es frm my ISP right?

    and thanks alot for help
  4. falko

    falko Super Moderator ISPConfig Developer

    That's the right setting.

    Yes. But make sure your domain registrar creates real A or CNAME records for your domain, not just some kind of forward. You can check this with
    You don't need that setting at all if all DNS records of your domains are managed by your registrar or someone else.

    Yes, as long as these are working DNS servers.
  5. razvan_vlad

    razvan_vlad New Member

    ok. so.. i unchecked the "Create DNS" and " Create DNS-MX" options for each website. i went to DNS Record and deleted all the records for each website.
    I went to Management - Server Settings - DNS and deleted the "Default Ns1:" and "Default Ns2:" so now they are empty.
    i went to up on the menu bar on fedora.. at System - Administration - Network -, i selected the eth0 and press DNS. there i have the primary and secondary dns which are the dnses provided by my ISP.
    now.. i "dig" and here's what i got
    where i just substitute them.

    and 2nd website that i have created without using ISPConfig (just made out the virtual host in httpd.conf):
    they still time out.
    here is my error_log under /var/log/httpd/
    and my ssl_error under the same folder :
    the access log files are empty.
    and under /root/ispconfig/httpd/logs i still have no error logs

    any help? :(
  6. falko

    falko Super Moderator ISPConfig Developer

    Is your public IP address?

Share This Page