Nearly Perfect Server Buster and ISPconfig - How to add additional PHP Versions

Discussion in 'HOWTO-Related Questions' started by AMS, Aug 1, 2019.

  1. AMS

    AMS New Member

    Dear All,

    last week i gave a try to ISPconfig and installed it on a test server. The perfect server tutorial was great and installation was easy. But I'm new to ISPconfig and there remains a question:

    How can I add additional PHP Versions to PHP 7.3? For compatibility I need 7.1 and 5.6 probably would be nice to have. Preferably i would not compile other versions but use the repository of sury.org.

    Is there somewhere a tutorial to do so? Do i need to uninstall original PHP7.3 from debian and use all Versions from sury.org or can additional packages just be added?

    Best regards
    Andreas
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. AMS

    AMS New Member

    Taleman, thank you, that points to the right direction. I'll give this a try over the weekend.

    Andreas
     
  4. kommid

    kommid New Member HowtoForge Supporter

    @Taleman the tutorial for debian 8 and 9 does not work with buster: I tried it, but the only version of php that was working, was the originally installed one. The installation went smooth without any errors, but somting prevents the additionally installed versions from running properly. I get an error: Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    Maybe the paths, that must be entered into ispconfig have changed?
    Markus
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The tutorial that @Taleman posted works fine on Buster, I use it on my Debian 10 servers. Just add the sury repo and then install all php versions that you want to use and finally add them in ISPConfig under System.
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I have just last week installed additional PHP versions on Debian 10 Buster using that tutorial. It is working as expected.
     
  7. kommid

    kommid New Member HowtoForge Supporter

    you're right, I tried it a second time, now it works.
     

Share This Page