Navigation by IP

Discussion in 'Installation/Configuration' started by tchouk, Feb 18, 2009.

  1. tchouk

    tchouk New Member

    I have a bit of a problem.

    1)I'm a bit of n00b in all this, but have volunteered...

    2) The domain name for my server was registered just today and the names for the eventual sites on it haven't even been decided yet (I'm not the one that takes care of that bit)

    I would like to, however, start setting sites up right now, because, well, I am the one that takes care of this and I'd like to have the maximum amount of time for coding/designing/whatever the actual site. I don't want to loose 3-4+ days waiting for DNS registers to propagate.

    I do have the (dedicated) IPs for the sites that I set up on the NIC via aliases (eth0:1 etc. - pinging the address works), so pointing my browser to the IP address of the site would be one way of getting to it.

    This isn't a problem for the ISPconfig web interface (I just point the browser to and it works w/o problems.

    When I point my browser to the site IP (which I entered in the Manegement->settings->IP list) I get a "bad request" error. When I point my browser to I get the "shared IP" standard page.

    Commenting this bit out in Vhosts_ispconfig.conf

    # ServerName localhost
    # ServerAdmin [email protected]
    # DocumentRoot /var/www/sharedip
    # <IfModule mod_rewrite.c>
    # RewriteEngine on
    # RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
    # RewriteRule .* - [F]
    # </IfModule>

    gets it to work, but only in a "sorta" kinda way. I mean the index.html shows up fine, but all the linking bits (php scripts etc) don't really work. (Or at least Joomla setup doesn't work - shows an empty "choose language" box w/o stiles or forms or buttons or whatnot) Probably because they don't have a ":80" bit on them in the end? It doesn't work without designating the port, I get a "400 error - invalid syntax!"

    What I wanted to ask was, how do I go about setting up ISPconfig so that the I can access the site just through its IP? Maybe enter the IP address as the domain, something silly like that?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Sites in ISPConfig are name based and can not be accessed directly by IP. Do not comment out the shared IP site or you get a security hole in your system!

    If you want to reach a site before the domain is propagated, add the domain and ip to the hosts file of your workstation.
  3. tchouk

    tchouk New Member

    I've done that anyway, and it works - from the server. But the problem is that the server is in a remote location and setting-up/testing a web site is kind of hard to do through putty and lynx.

    Also - does anyone know if this is, in fact, the reason the Joomla setup isn't working?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I talked about the hosts file on your workstation and not the server. Joomla setup is working fine on ispconfig, there is even a howto about tit on howtoforge.
  5. tchouk

    tchouk New Member


    Ah yes, of course! That works just fine.

    Thank you!

    Although now I do feel like an idiot :)
  6. bl4ckb1rd

    bl4ckb1rd New Member

    acutally adding a temporary subdomain and working on it would solve your issue... Add a subdomain and setup pages you need until the real domain is fully working.

Share This Page