NAPTR added but " is replaced with \"

Discussion in 'General' started by ibc, Nov 2, 2008.

  1. ibc

    ibc New Member

    In order to support NAPTR DNS entries I've added "NAPTR" in files:
    • web/dns/form/rr.tform.php
    • web/dns/list/rr.list.ph

    so now I can enter a NAPTR entry.

    But there is something wrong: I insert a ENUM NAPTR entry like this:
    • Name: 9.8.7.6.5.4.3.2.1
    • Type: NAPTR
    • Data: 100 10 "u" "E2U+sip" "!^.*$!sip:[email protected]!i" .

    But MyDnsConfig inserts the following into database:
    Code:
    100 10 \"u\" \"E2U+sip\"  \"!^.*$!sip:[email protected]!i\" .
    This is totally wrong since before storing the data the data is escaped and " is replaced by \". Of course " shouldn't be escaped in order a NAPTR entry to work.

    Where exactly is done this espace processing? how could I change it?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make sure that magic_quotes_gpc is disabled in your php.ini
     
  3. ibc

    ibc New Member

    Great, it works!

    PD: I suggest to add NAPTR officially in the code since it's just adding the word "NAPTR" in 2 files.

    Thanks a lot.
     

Share This Page