Named Problem

Discussion in 'Installation/Configuration' started by mufasa, May 22, 2008.

  1. mufasa

    mufasa New Member

    I have searched and searched for a solution to my problem but cannot seem to find an answer, can anyone please help me with this:

    Using Fedora 7

    When Trying to start the service named I get:

    I have followed the perfect server setup for bind to the letter numerous times:

    Still get the same error!

    My DNS settings on ispconfig are:

    BIND User: named
    BIND Group: named

    Named.conf : /var/named/chroot/var/named/
    Zonefiles Dir: /var/named/chroot/var/named/

    The Output of ls -la /var/named/chroot/var/named is:

    Can anyone please give me some advice on this as I am now stuck!

    Any help will be greatly appreciated

    Thank-you

    John
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you disable SELinux?
     
  3. mufasa

    mufasa New Member

    Hi Falko

    Yes SELinux is disabled

    Thanks

    John
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/named.conf?

    What are the outputs of
    Code:
    ls -la /var/named/chroot/var/named
    and
    Code:
    chroot /var/named/chroot
    ls -la /var/named/chroot/var/named
    ?
     
  5. mufasa

    mufasa New Member

    Hi Falko

    Thanks for the reply

    I cannot find a file called named.conf in /etc/

    Here are the other results:

    and

     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's in /var/named/chroot/etc/named.conf?
     
  7. mufasa

    mufasa New Member

    Thanks

    John
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Can you post the outputs of
    Code:
    ls -la /var/named/
    ls -la /var/named/chroot/
    ls -la /var/named/chroot/var/
    ls -la /var/named/chroot/var/named
    ?
     
  9. mufasa

    mufasa New Member

    Thanks for the help

    John
     
  10. falko

    falko Super Moderator ISPConfig Developer

    Everything's looking ok. I'm not sure where the error is... :(
     
  11. mufasa

    mufasa New Member

    OK now i'm stuck

    Anybody have any ideas as to what I can do now?

    Thanks

    John
     
  12. kike

    kike New Member

    Hi

    i think the error is in ispconfig setting

    -------------------------------you have:
    My DNS settings on ispconfig are:

    BIND User: named
    BIND Group: named

    Named.conf : /var/named/chroot/var/named/
    Zonefiles Dir: /var/named/chroot/var/named/

    ------------------------------------------------

    the normal path is:
    Named.conf : /var/named/chroot/etc/named.conf
    Zonefiles Dir: /var/named/chroot/var/named

    change and wait for 15 minutes+-
    and restart named.
    regards
     
  13. mufasa

    mufasa New Member

    Hi

    No that didn't work eiether

    Thanks

    John
     
  14. lowfatbuddha

    lowfatbuddha New Member

    had same problem

    the trouble seems to be that bind cannot parse zone file setup and so gives up. i had to make sure that the exact same zone files were present in the named directory as were in the bind server module in webmin o/wise it goes lame like this - the trouble started when i was setting up master zones tetc. thru webmin - so i deleted them and started again - then i realised that there were some zone files that had been created by ispconfig while i was testing it out - and webmin just reloaded them again !

    i am not sure if these old files will still keep popping up but named is working sweet now anyway so i don't mind
     
  15. mufasa

    mufasa New Member

    Sorry if this is a stupid question but must I then delete the zones in webmin?

    root
    10.10.1
    127.0.0

    There are to master zones setup in ispconfig.

    Thanks for the help

    John
     
  16. lowfatbuddha

    lowfatbuddha New Member

    possibly - i think the reason is that the ispconfig entries have to come first and any webmin stuff has to go below before you can named restart via shell:-

    //// MAKE MANUAL ENTRIES BELOW THIS LINE! ////

    in /var/named/chroot/etc/named.conf

    check that this file matches your ispconfig setup and that you have all the corresponding zone files present in the zone dir

    using webmin and ispconfig alternately i think corrupts the file for either one ?

    if i remember correctly - as it was two days ago i was struggling with it - the next stage you can get to is something like:-

    [root@host ~]# /etc/init.d/named start
    Starting named:
    Error in named configuration:
    /etc/named.conf:3: change directory to '/var/named/chroot/var/named' failed: MISSING ZONE FILES

    /etc/named.conf:3: parsing failed
    [FAILED]

    this might mean that named conf is being parsed a little before it errors out ? you then just need to replace some zone files to match your config and then it will start - rather than the "failed: file not found" error you are getting

    i guess i just got lucky ?
     

Share This Page