named issue

Discussion in 'Installation/Configuration' started by smartcall, Jan 18, 2007.

  1. smartcall

    smartcall ISPConfig Developer ISPConfig Developer


    I have the following issue with named:
    I use ISPConfig 2.2.9 on FC6 with chroot named

    All was OK till today.
    I have a few domains on that server.
    All of them are resolving when I type 'dig @server domain' except one, which stopped resolving today.
    What is different with this domain is that it has about 20 subdomains that I added since yesterday, because I run a test hostin service and my test clients are using subdomains to this main domain.
    The records in the zone file are correctly written and all seems OK regarding the configuration.
    The only thing is that the subdomains stopped resolving from one point.
    The main domain and some of the subdomains that I created earlier are still resolving due to the fact that are cached and due to the secondary DNS.
    I don't have the subdomains in the secondary dns.


  2. smartcall

    smartcall ISPConfig Developer ISPConfig Developer

    output of dig

    This is what I get:

    dig @

    ; <<>> DiG 8.3 <<>> @
    ; (1 server found)
    ;; res options: init recurs defnam dnsrch
    ;; got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 30950
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    ;;, type = A, class = IN

    ;; Total query time: 17 msec
    ;; FROM: to SERVER:
    ;; WHEN: Thu Jan 18 20:07:06 2007
    ;; MSG SIZE sent: 35 rcvd: 35
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Please stop bind with the script in /etc/init.d/, then check with the command "ps -aux" if there are still some bind / named processes running. Kill these processes with the command "kill -9 [PROCESSID]", then start bind again.
  4. smartcall

    smartcall ISPConfig Developer ISPConfig Developer

    no other processes

    I stopped named, but there are no other processes with its name. I tryed also ps aux | grep named.
    Can you think of any other reason?

  5. smartcall

    smartcall ISPConfig Developer ISPConfig Developer

    illegal name

    Sorry for the mess,

    there was an illegal subdomain name which caused it all



Share This Page