named - /etc/named.conf.local: file not found

Discussion in 'Installation/Configuration' started by IceVilli, May 16, 2011.

  1. IceVilli

    IceVilli New Member

    Hi
    I installed ispconfig3 following instructions http://www.howtoforge.com/perfect-server-fedora-14-x86_64-ispconfig-3

    Everything looks fine except for the DNS server, it will not start.
    I tried installing again but I unfortunately get get the exactly the same result.

    This is the /etc/named.conf
    Any ideas what could be wrong?
     
  2. falko

    falko Super Moderator

    Can you replace the last line with
    Code:
    include "/var/named/chroot/var/named/named.local";
    and restart BIND?
     
  3. IceVilli

    IceVilli New Member

    Hi falco and thank you for quick response.

    I replaced the last line as you suggested.

     
  4. IceVilli

    IceVilli New Member

    Furthermore I can not find any file named "named.local" on the system

    Im using Linux version 2.6.35.13-91.fc14.x86_64
     
  5. till

    till Super Moderator

    Did you create already a DNS zone from within ISPConfig? The file you miss is created automatically when you add the first zone.
     
  6. IceVilli

    IceVilli New Member

    I had not created a zone but now I have.
    I changed the last line in the /etc/named.conf back to its original value. (it does not start if the value is "include "/var/named/chroot/var/named/named.local";)
    The named server now starts :D

    • ispconfig3 - states the DNS is running
    • service named status - states the DNS is running
    ...but

    My firewall is disabled and Nmap does not see the named server on port 53.


     
  7. till

    till Super Moderator

    To check the nameserver, use the dig command:

    dig @localhost yourdomain.com
     
  8. IceVilli

    IceVilli New Member

    Thank you till and falco.

    I guess this is working now

    Still.... shouldn't "named" on port 53 be visible in the list generated by Nmap?
    Sorry for the question...I'm kind of a noob in this!

     
  9. till

    till Super Moderator

    currently named listens only on localhost. To configure bind to listen on all interfaces, change the line:

    listen-on port 53 { 127.0.0.1; };

    to:

    listen-on port 53 { any; };

    in named.conf file and restart bind.
     
  10. IceVilli

    IceVilli New Member

    Thats it. Now it works great. Thanks guys!
     
  11. sjswarts

    sjswarts New Member

    Hi guys

    I also have ispconfig 3 running and the DNS all of a sudden couldn't find the named.conf.local which should be in the /etc/ directory.

    However looking there it is there along with named.conf then named.conf.local but it just can't open it.

    In named.conf it states:

    include "/etc/named.conf.local";

    which seems right but upon trying to start it, the error comes out as unable to start:


    Starting named:
    Error in named configuration:
    /etc/named.conf:47: open: /etc/named.conf.local: file not found
    [FAILED]

    I have created a zone in ISPConfig 3 and I've tried deleting it and remaking it and nothing helps.

    Thanks for your time
     
  12. sjswarts

    sjswarts New Member

    bump people...
    bump
     
  13. tianying

    tianying New Member

    hello IceVilli , I had install ISPconfig3,
    /etc/init.d/named start
    warning : named - /etc/named.conf.local: file not found
    Could you tell me how to solve this warning !!
    If
    include "/var/named/named.localhost"; ??
     
  14. falko

    falko Super Moderator

    Which distribution do you use? Which tutorial (URL) did you use to set up the system?
     
  15. sjswarts

    sjswarts New Member

    Stopping named: [ OK ]
    Starting named:
    Error in named configuration:
    /etc/named.conf:46: open: /etc/named.conf.local: file not found
    [FAILED]

    I used ISPConfig3 for fedora 14.... http://www.howtoforge.com/perfect-server-fedora-14-x86_64-ispconfig-3-p6

    /etc/named.conf contains this (extract)
    ...
    include "/etc/named.conf.local";
    ...

    /etc/named.conf.local contains this
    ...
    zone "example.com" {
    type master;
    allow-transfer {none;};
    file "/var/named/pri.example.com";
    };
    ...

    the permissions on named.conf.local are 660 with root being owner and named being group

    I have just read this post:

    http://www.howtoforge.com/forums/showthread.php?t=47105&page=4

    and that told me a critical piece of info:

    ISPConfig 3 - Perfect Server Fedora 14
    remove chroot-bind

    as soon as I did that it obviously started looking in /etc/ directory as opposed to /var/named/chroot/etc/

    so problem solved for me at least

    thanks to above post, very helpful
     
  16. ACDII

    ACDII Member

    Hi guys, I have the exact same issue, but the named.conf.local file does exist exactly where its listed on the named.conf file.

    Jul 10 13:28:35 NServ1 named: /etc/named.conf:46: open: /etc/named.conf.local: file not found
    Jul 10 13:28:35 NServ1 systemd[1]: named.service: control process exited, code=exited status=2
    Jul 10 13:28:35 NServ1 systemd[1]: Unit named.service entered failed state.


    The named.conf.local file does list all the zones that I imported too.


    NM, Stupid zone file I imported was the problem, learned not to edit the file while ISPConfig web interface was active.
     
    Last edited: Jul 10, 2012

Share This Page