named /etc/named.conf:44: open: /etc/named.conf.local: file not found

Discussion in 'Installation/Configuration' started by postcd, Oct 4, 2019.

  1. postcd

    postcd New Member

    after i installed ISPConfig (ISPConfig Version: 3.1.15) on CentOS 6.10 64bit, and added DNS zones + domain names, i see the server is not responding to remote DNS queries.

    # rpm -qa|grep bind
    # service named status
    # service named start
    ISPConfig shows fake DNS-server status "Online" on Monitor / Show Services. (can anyone fix it?)

    System / Server Config / DNS shows:
    Bind user: named
    Bind goupd: named
    Zonefiles dir: /var/named/chroot/var/named/
    Named.conf path: /var/named/chroot/etc/named.conf

    cat /var/named/chroot/etc/named.conf
    # cat /var/named/chroot/var/named/named.local
    cat /etc/named.conf
    see the output here please

    # locate named.conf
    When i searched for files matching the domain name i added, it only found .err file in /var/named/chroot/var/named/
    Re-adding DNS zone does not help.
    But for the second domain i added it found number of files.

    When i edit /etc/named.conf and comment out include "/etc/named.conf.local" and instead use "/var/named/chroot/var/named/named.local", the named starts and shows status:
    But tools like still shows that no domain A record is resolved (timeout). Please what to try?
    Last edited: Oct 4, 2019
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's the reason for your problem, you probalby missed to add some records, otherwise BIND would not have rejected the zone. The most common mistake is to use a subdomain of the zone itself for the NS records without having added A-Record for these subdomains.

    And a side note: Why did you install ISPConfig on such an outdated OS? CentOS 6 is really really old and support for it in ISPConfig is about to be removed, so you will not be able to update ISPConfig on your server without updating to centOS 7 first, why did you not used the recent CentOS 7?
  3. postcd

    postcd New Member

    It is possible that i messed something, but the software GUI should be made the way i do not miss anything and if i do, the software should warn me. I am giving up, because i spent enough time and i was not given any exact steps what to do, i am not an expert that is told to "check DNS" and i would know how exactly. I did my best to describe the issue so it can be solved, though it is not solved. Exact root cause not found.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I told you what you probably missed to add, you did not post any details of the zone, so how shall we be able to help you? Post screenshots of the dns zone in ISPConfig, the first tab and the records tab. The software can not guess what you want to do, so it can not warn you in such a case.
  5. postcd

    postcd New Member

    I have not posted it, because possibly i thought it is some error that can be discovered running commands via command line or maybe i thought it is obvious it is full of private details i do not want to reveal. So thanks for letting me know what exactly i need to do. I spent my time and here are the screenshots:
    Please PM me if is necessary to talk about private data.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is that you have hidden the relevant details on the screenhshots. The ns1 and ns2 in the data row on the second screenshot, are these subdomains of the domain name of this zone. Or in other wirds, if the zone name is, are theese and ?
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  8. postcd

    postcd New Member

    The zone is of, but the ns1, ns2 are of other domain:, while the domain registar has these nameservers registered and pointed to ISPConfig server IP. Then in DNS zone of the (hosted on non ISPConfig server) are DNS A records ns1, ns2 set to ISPConfig server IP. I check these nameservers (ns1,ns2) A record on and it resolve properly to ISPConfig server IP. confirms that too, but it says "Missing nameservers reported by your nameservers" and "ERROR: I could not get any A records for!" - i think (may be wrong) these erros means that ISPConfig DNS is not responding/working.

    @Taleman thanks, i checked that, i do not think there is any error in what i input into the ispconfig DNS forms. I tried some of the commands mentioned but have no clue if i used the ips and hostnames in it correctly as it timeouts. Fastet way to solve this bothering issue is to tell me CentOS Linux commands i need to execute, so we get to the core of the problem. Some of the paths in commands mentioned in that tutorial not found/not applicable on my system.

Share This Page