named does not start

Discussion in 'Installation/Configuration' started by cassola-enterprises, Aug 19, 2016.

  1. I am installing a CentOS 7 server according to these instructions:
    https://www.howtoforge.com/tutorial...l-php-pureftpd-postfix-dovecot-and-ispconfig/

    I am unable to start named.

    This is the output of:
    systemctl status named.service -l

    ‚óŹ named.service - Berkeley Internet Name Domain (DNS)
    Loaded: loaded (/usr/lib/systemd/system/named.service; enabled; vendor preset: disabled)
    Active: failed (Result: exit-code) since Fri 2016-08-19 08:42:47 EDT; 52min ago
    Process: 11892 ExecStartPre=/bin/bash -c if [ ! "$DISABLE_ZONE_CHECKING" == "yes" ]; then /usr/sbin/named-checkconf -z /etc/named.conf; else echo "Checking of zone files is disabled"; fi (code=exited, status=1/FAILURE)

    Aug 19 08:42:47 server systemd[1]: Starting Berkeley Internet Name Domain (DNS)...
    Aug 19 08:42:47 server bash[11892]: /etc/named.conf:30: open: /etc/named.conf.local: file not found
    Aug 19 08:42:47 server systemd[1]: named.service: control process exited, code=exited status=1
    Aug 19 08:42:47 server systemd[1]: Failed to start Berkeley Internet Name Domain (DNS).
    Aug 19 08:42:47 server systemd[1]: Unit named.service entered failed state.
    Aug 19 08:42:47 server systemd[1]: named.service failed.

    Can anyone please help me make it work?
    Thank you in advance!
     
    Last edited: Aug 19, 2016
  2. I found the solution:
    touch /etc/named.conf.local
    An empty file bind couldn't live without :)
     

Share This Page