named.conf for ispconfig

Discussion in 'Installation/Configuration' started by davy, Apr 8, 2010.

  1. davy

    davy New Member


    I change from mydns to bind. Can anyone know how to setup the named.conf file?

    I got a below error when i start the named service:

    [[email protected] ~[11:13 AM]]#service named start
    Starting named:
    Error in named configuration:
    /etc/named.conf.local:1: when using 'view' statements, all zones must be in views

    Thanks a lot.
    Last edited: Apr 8, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not use views, it writes just normal dns zone records into the named.conf.local file. Please check your named.conf and remove the views.
  3. QuetzalFirst

    QuetzalFirst Member


    In named.conf generate by ispconfig3, the line contain // which, i think, is a bug..
    file "/var/named/chroot/var/named//slave/sec.mydomain

    workaround : remove last / in " BIND zonefiles directory "
    Thank you
    Last edited: Mar 28, 2015
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The path is freely configurable. I guess you entered a / at the end of the named conf path in the servers ettings. Remove that slash.
  5. QuetzalFirst

    QuetzalFirst Member


    Thank you... Sure, that make sense for slash...
    Now all work... I fix problem... But... I have to put :
    include "/var/named/chroot/var/named/named.local";
    at the end of
    in place of
    include "/etc/named/named.conf.local

    That look like a bug no? Or i forget something. It's look BIND is half chrooted :S
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The named.conf file is neither managed nor altered by ISPConfig at all. You as administrator have to set the include line in that file before you install ISPConfig. If you use a chrooted bind, then set the chroot directory there. If you setup a non chrooted bind, then use the path without chroot. The path in System settings in ISPConfig has then set to the path that you have chhosen for the named config files of your server.
  7. QuetzalFirst

    QuetzalFirst Member

    But, i follow guide in how to forge (perfect server)
    1) install bind (basic, dont touch config)
    2) Install ISPConfig3... In the DNS tab the path is default to "/../chroot/../named.conf" and no indication that is to be set...
    So 1) remove default or 2) indicate that it's a config to set... (not in ISPConfig3 but in the "how to" )
    Now all work fine...

    For the named.conf, there is a "nice to have" here... Managed options of BIND rigth in ISPConfigs... But chanllenge for others nameserver...

Share This Page