Name servers software versions are exposed

Discussion in 'Server Operation' started by onastvar, Jan 3, 2014.

  1. onastvar

    onastvar Member

    I've got the following from dnsinspect.com:

    WARNING: Name servers software versions are exposed:

    123.123.123.123: "9.8.4-rpz2+rl005.12-P1"

    Exposing name server's versions may be risky, when a new vulnerability is found your name servers may be automatically exploited by script kiddies until you patch the system.


    Is this something to be worried about, how to get rid of this warning?

    Thanks!
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You can set version in /etc/bind/named.conf to something like "DNS server" or "use fpdns to get version number ;)". Afterwards restart bind.
     

Share This Page