Name servers not propagating

Discussion in 'ISPConfig 3 Priority Support' started by ginner159, Jul 17, 2014.

  1. ginner159

    ginner159 New Member

    Hello ive setup my nameservers as glue records for my domain over 48 hours ago, the bind folder has the all the zonefiles there its just not propagating? and i can see why?:confused:
  2. srijan

    srijan New Member HowtoForge Supporter

    If you like to test the local dns server for a domain name without waiting for the caches to renew, use this command:


    Post the errors of the named daemon (the BIND dns server logs under the name named) from /var/log/syslog
  3. ginner159

    ginner159 New Member

    hello sorry for the late reply been on a stag weekend.

    i cant seem to find any logs for it when i type that command in? i did remove Apache from the dns servers if that has anything to do with it but i assumed not?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    apache should not be related to that.

    Which output do you get on the shell when you run:

    dig @localhost yourdomain.tld

    replace yourdoamin.tld with the domain name that you configured in bind.
  5. ginner159

    ginner159 New Member

    heres the output on ns1 and ns2

    ; <<>> Dig 9.8.4-rpz+r1005.12-p1 <<>> @localhost
    ; (2 servers found)
    ;; global options: +cmd
    ;; connection timed out; no server could be reached
    hers the output on srv1 (where ispconfig is installed) where i had originally had my dns set up before trying to add these

    ; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> @localhost
    ; (2 servers found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58241
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
    ;               IN      A
    ;; ANSWER SECTION:        3600    IN      A
    ;; AUTHORITY SECTION:        3600    IN      NS        3600    IN      NS
    ;; ADDITIONAL SECTION:    86400   IN      A    86400   IN      A
    ;; Query time: 0 msec
    ;; SERVER:
    ;; WHEN: Mon Jul 21 16:39:26 2014
    ;; MSG SIZE  rcvd: 117
    i have re-synced the dns queries and made sure that ns2 is a mirror on ns1 and that srv1 is set not to do dns.

    also there are dns zone files on ns1 + 2 for the domain
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The dns server is working correctly. so you should search for the issue elsewere. E.g. check if bind is listening on the external interfaces:

    netstat -tap

    and if there is no firewall blocking the dns queries.
  7. ginner159

    ginner159 New Member

    heres what i get. im assuming this means its not running correctly

    [email protected]:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost.localdom:smtp *:*                     LISTEN      1981/sendmail: MTA:
    tcp        0      0 localhost.localdo:mysql *:*                     LISTEN      2475/mysqld
    tcp        0      0 localhost.lo:submission *:*                     LISTEN      1981/sendmail: MTA:
    tcp        0      0 *:ssh                   *:*                     LISTEN      2023/sshd
    tcp        0      0 TIME_WAIT   -
    tcp        0     52 host-80-193-74-19:53209 ESTABLISHED 9514/0
    tcp        0      0 TIME_WAIT   -
    tcp6       0      0 [::]:http               [::]:*                  LISTEN      26927/apache2
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      2023/sshd
    [email protected]:~#
    restarted bind9 got an error saying cannot bind to port. stopped it and started it again boom! whatsmydns shows it all around the world yay!
    i always forget about netstat! cheers till your the man!
    Last edited: Jul 22, 2014

Share This Page