name server and dns not working properly

Discussion in 'Installation/Configuration' started by theleech1, Jul 8, 2010.

  1. theleech1

    theleech1 New Member


    I used the The Perfect Server - CentOS 5.5 x86_64 [ISPConfig 3] using Bind and Chroot. I got it all to install fine by changing the x64 to i386 where necessary. BUT I am getting this error - Error in named configuration:
    /etc/named.conf.local:1: zone '': already exists previous definition: /var/named/chroot/etc/named.conf.local:1


    I bought a domain. from enom. I added a name server at the registry to my IP address of (not real but looks better than x.x.x!)

    on my machine in my basement behind a firewall I have Bind, Apache, the lot on

    I have got Ispconfig working but have made a mess of something because i want to use as both a ns1 on my local machine and also to use it as a www but the does not dig or resolve . Later I will add to this when I get it working.

    My trouble is that the ns1 is not working. when I run ...named restart I get this error -

    Now those files are sylinked as part of chroot.

    When I remove the DNS Zone under DNS I get this:

    Now here are my settings under dns-dns zone after I add a dns dzone using the DEFAULT wizard.

    (dont know how to embed screenshots or I would have done that.

    Now as this is a template it does create these when you go in and look. and yes it does put the "." after the .com
    So even if I delete it and created it with (with the correct IP) it still gives the error.

    I am sure if I can sort this out then I can get it all to work :(

    Thanks for helping in advance.
    Last edited: Jul 8, 2010
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Must be a problem with the named chroot setup. Post the content of the file /var/named/chroot/etc/named.conf.local and the output of:

    ls -la /etc/named.conf.local

    which guide did you follow to install a chrooted named?
  3. theleech1

    theleech1 New Member


    Thanks for trying to help. You are a champion and I see you help everyone :)

    Your answers:

    /var/named/chroot/etc/named.conf.local - I just changed the domain to xyz below thats all.

    ls -la /etc/named.conf.local

    I have noticed this "//" whenever i link to the chroot. I have not seen it when I ahve done it elsewhere. but maybe thats a special Chroot thing - I was trying to look intot hat but try putting "//" into Google!

    Also I have only created 1 user "root" and I had to change the permissions on "named" to allow root. Otherwise I have followed all this - entry 17-

    There is something very fishy here :)
  4. theleech1

    theleech1 New Member


    I played with it over the weekend and solved it myself.

    It was the Bind-chroot install that got messed up plus something in the named.comf that was used here that did not work on my vmware version.

    I removed the whole bind and installed it again. then the original problem here was solved.

    the next problem was that it just did not work....! So I went and used a very simple named.conf from one of my other servers. There is one of the settings in this tutorial that did not work on the vmware.

    I am not going to research it further as this was just a wekeend project to install Centos on a vmserver on my main machine for fun... and it was but i burnt alot of hours on it.. glad the weather was perfect for playing on the computer.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    If you want to setup a production system with ispconfig 3, I can highly recommend to use debain. Centos causes a lot more problems then debian installs.
  6. theleech1

    theleech1 New Member

    thanks Till. This was just a weekend project. The reason I decided to play with Centos is that I **thought** most of the BIG web hosting companies around the world use Centos.....

    i know it is like do you prefer a BMW to an Audi...

    But in this case it seemed that Centos won by a mile.

    anyway this project was just for fun and I might use it to host a few type sites.. so who cares if they are offline for the weekend while I play with a new setup.

    this machine is in the basement on a wireless connection so it cant be used for anything but.... if someone out there wants me to host their site on this then I will do it for $1,000 per month :)

Share This Page