Name resolution works before starting ispconfig_server

Discussion in 'Installation/Configuration' started by mkommar, Mar 26, 2009.

  1. mkommar

    mkommar New Member

    Hi All,
    Thanks for a great product and support. I seem to have ISPConfig setup and running correctly. On first boot, ISPConfig isn't running but the other services are started.

    In this configuration, I can resolve external addresses:

    Code:
    -bash-3.2# ping google.com
    PING google.com (74.125.45.100) 56(84) bytes of data.
    64 bytes from yx-in-f100.google.com (74.125.45.100): icmp_seq=1 ttl=248 time=1.53 ms
    64 bytes from yx-in-f100.google.com (74.125.45.100): icmp_seq=2 ttl=248 time=2.67 ms
    However, when I start ispconfig_server with /etc/init.d/ispconfig_server restart

    (And enter the passphrase for the SSL cert) DNS resolution no longer works for anything outside of the hosted domains. Stopping ISPConfig and restarting BIND doesn't change the situation. All the services that ISPConfig manages work properly regardless of which scenario except the external resolution of domains. I can start ISPConfig (thereby losing external DNS resolution) create/alter accounts and restart the server and retain the settings and have the resolution of names I need... However, since the server restarted, ISPConfig isn't running and thus the process repeats.

    Any advice is appreciated.
     
    Last edited: Mar 26, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    Which distribution are you using?

    Do you use a firewall on the system and have switched on the ISPConfig firewall? In that case, both firewalls most likely interfere with each other.
     
  3. mkommar

    mkommar New Member

    Thanks for the help falko.

    Prior to starting ISPConfig

    Distro:
    Code:
    -bash-3.2# cat /etc/redhat-release
    CentOS release 5.2 (Final)
    Firewall:
    Security Level:
    Starting ISPConfig:
    Firewall is on in ISPConfig

    Going to:
    Management -> System Config -> Settings -> Firewall Tab

    Checking iptables seems to show the correct info?
    I'm starting to get the impression I'm missing something obvious here. =)

    Thanks again for your help.
     
  4. mkommar

    mkommar New Member

    And... Disabling the firewall in ISPConfig makes external resolution work again... Re-enabling firewall makes it break. Am I missing a port to open?
     
  5. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/resolv.conf?
     
  6. mkommar

    mkommar New Member

    The contents of this file doesn't seem to change when turning firewall on and off. The first nameserver is the IP of the ISPConfig host... Would it be better to set it to localhost?
     
  7. falko

    falko Super Moderator ISPConfig Developer

    Please try an external nameserver as the first nameserver, e.g. from your ISP.
     
  8. mkommar

    mkommar New Member

    Using the other two nameservers as the first nameserver didn't seem to change anything. I'll see if I can add the iptables rules manually and see if they work.
     

Share This Page