Name or service not known

Discussion in 'Installation/Configuration' started by kama_k, Dec 1, 2006.

  1. kama_k

    kama_k New Member


    I am having a problem with one particular domain where they don't appear to have n mx record but I know they exist(one of our biggest customers) and the log file gives me -

    Dec 1 10:35:58 promotheus postfix/smtp[21508]: 344A7E80B8: >, relay=none, delay=0, status=bounced ([domain]: Name or service not known) a dummy entry for what it actually in the log

    My looks like this:

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    mailbox_command =
    mailbox_size_limit = 0
    recipient_delimiter = +
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,rejec

    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    home_mailbox = Maildir/

    virtual_maps = hash:/etc/postfix/virtusertable

    mydestination = /etc/postfix/local-host-names
    smtpd_client_restrictions = permit_mynetworks, reject_rbl_client
    , reject_rbl_client,permit
    message_size_limit = 100000000
    maximal_queue_lifetime = 1d

    The email appears to be going to everyone else fine just this customer
    Any help much appreciated, my ears getting a bashing.

  2. kama_k

    kama_k New Member


    Just found out the customer's dns has a problem, does my look ok? been getting a lot of spam recently.

    Thanks again

  3. falko

    falko Super Moderator ISPConfig Developer is ok, however I recommand you run
    postconf -e 'mynetworks ='
    /etc/init.d/postfix restart
    to avoid that you have an open relay.
  4. kama_k

    kama_k New Member


    Thanks for the reply, all the clients have internal ips like 192.168.0, would I still use

    Is there anyway I can configure outgoing mail to only come from these ips?

    Thanks again

  5. falko

    falko Super Moderator ISPConfig Developer

    Everyone using an email client must enable "Server requires authentication." in the email client, then they can send emails.

Share This Page