[Mysteriously solved] Server unreachable

Discussion in 'ISPConfig 3 Priority Support' started by axxies, Jun 17, 2020.

  1. axxies

    axxies Member

    For some reason I can no longer reach my ISPconfig3 installation. I could just a few days ago and now I can't.
    There are no firewall issues.
    I am able to reach other sites on my server.
    It's just that the ISPconfig does not respond. I have tried with Edge, Chrome and Firefox. (I don't trust Firefox anymore, they have screwed it up completely since a few years and it just becomes worse and worse with every version)

    Nothing in the logs for it either under /var/log/apache2/error.log etc
     
    Last edited: Jun 17, 2020
  2. sascha92

    sascha92 New Member HowtoForge Supporter

    Hi,
    what is your setup? Single, Multiserver?
    Do you host your ISPConfig with your Websites together? If single, the nginx service should not be the problem, only a missconfiguration of the default conf maybe.
    Have you tried the port :8080 to reach ISPConfig? Have you changed the port?
    What is the error, when you try to open your panel in the browser?
     
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run the test script that you can find in the thread that @Taleman suggested so we get an overview.
     
  5. axxies

    axxies Member

    Yes, you are all right. I apologize. I gave hardly any useful info at all. :)
    It's a single server on LAMP with Debian 9. Port 8099 is where ISPconfig is listening.
    A result of a very late evening and stress to make it work. Here we go:

    ------

    htf_report: please see attachment
     

    Attached Files:

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Try using wget on the same server to access the ispconfig UI URL. Is wget able to retrieve that page by https or does it throw an error?
     
  7. axxies

    axxies Member


    --2020-06-17 13:56:21-- https://mydomain:8099/
    Resolving mydomain (mydomain)... 144.76.*.*
    Connecting to mydomain (mydomain)|144.76.*.*|:8099... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: /login/ [following]
    --2020-06-17 13:56:21-- https://mydomain:8099/login/
    Reusing existing connection to mydomain:8099.
    HTTP request sent, awaiting response... 200 OK
    Length: unspecified [text/html]
    Saving to: ‘index.html’

    index.html [ <=> ] 6.39K --.-KB/s in 0s

    2020-06-17 13:56:21 (132 MB/s) - ‘index.html’ saved [6548]


    --------------

    The HTML code of the index.html page looks normal.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so it must be a problem in a firewall or other system that might block access in front of the server which blocks port 8099 in my opinion. Have you tried to stop ufw firewall completely for a test to see if you can access the ISPConfig Ui then?
     
  9. axxies

    axxies Member

    Yes, I did that. Sorry, I forgot to tell. I stopped the ufw service, but it didn't work.
    It didn't work.
     
  10. axxies

    axxies Member

    Any ideas of what other problems there might be that can block access?
    I tried to access it through a VPN proxy to make sure that I was not banned by fail2ban, but that didn't work either.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Where do you host that server? Many providers run an external firewall in front of the server or server, so it might be that the port is blocked there. Or try using a different port temporarily.
     
  12. axxies

    axxies Member

    You mean that it would be changed lately, the last few days?

    It's with Hetzner, a German hosting provider. I have used them for years and "always" had my ISPC3 installations on p8099.

    But you are right. I will check with them if there are any changes.
     
  13. axxies

    axxies Member

    Tried port 8080 too (and added that port in UFW), but it was the same result
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Which exact message do you get in your web browser?
     
  15. axxies

    axxies Member

    Two examples, Edge and Firefox:
     

    Attached Files:

  16. axxies

    axxies Member

    How do I whitelist an IP in fail2ban?
    (it shouldn't be this problem since I have tried a VPN proxy)

    [EDIT: Found it. Never mind]
     
  17. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    Are you sure the hostname is pointed at the correct IP adress?
     
  18. axxies

    axxies Member

    Yes, it does.
     
  19. axxies

    axxies Member

    Whoa! This was the weirdest ever. I was using a router from my ISP since my Ubiquity router was broken. I have used the ISP router for a few weeks without any problems.

    Now however I had this problem. After trying to all kinds of things I came to think of testing if I could see the ISPC3 login page from my mobile over 4G. It worked, but over WiFi it didn't.
    I also tested again to access it via a VPN proxy, but that didn't work either.

    Now things pointed either to my network's router or my ISP.

    I went away to buy another router since I disliked the junk that came from my ISP so sooner or later I would change it anyway and -voila- it worked.

    I see no other explanation than that the router was the problem:

    1) might it be my ISP who fiddles with things on my network with their custom firmware in the router? I don't know, but my router currently seem to be the problem.

    2) with the new router also came a new IP address, but since I had tried another IP before via a VPN proxy this seem not to be the explanation.

    3) since it works now on p8099, it seem not to be so that the ISP is filtering out p8099.

    4) the support at Hetzner could get access to ISPC3 from their location.

    Although (1) seem far-fetched, it still seem to be the only probable explanation.

    Case closed.
     
    Th0m likes this.
  20. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    Some routers block outgoing traffic to "weird" ports (for example everything except http, https, smtp, smtps, imap, imaps, pop, pops3), though usually that only happens when you set it up like that or if you are using a guest network. Glad to hear it was solved for you :)
     

Share This Page