mysql_connect() warning when logging into ISPConfig

Discussion in 'Installation/Configuration' started by jasmith86, May 12, 2008.

  1. jasmith86

    jasmith86 New Member

    I have followed the Perfect Server setup guide for Ubuntu 8.04 Server (http://howtoforge.com/perfect-server-ubuntu8.04-lts). My issue is that when I try to log into the ISPConfig Control Panel, I get the following error message (I can get to the login page, but it shows this message once I type in my username/password):

    Code:
    Warning: mysql_connect() [function.mysql-connect]: Host 'XXXX.comcast.net' is not allowed to connect to this MySQL server in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77
    
    Warning: mysql_connect() [function.mysql-connect]: Host 'XXXX.comcast.net' is not allowed to connect to this MySQL server in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77
    
    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60
    
    I tend to think that I have entered in something into ISPConfig incorrectly during the setup process (database password or maybe database name), but I am honestly stuck. I tried looking around the forums and searching in Google, but really did not find anyone with this same issue.
    As far as I can tell, mysql is up and running -- this is what netstat puts out
    Code:
    # netstat -tap | grep mysql
    tcp        0      0 *:mysql                 *:*                     LISTEN      14677/mysqld
    # netstat -tap | grep isp
    tcp        0      0 *:81                    *:*                     LISTEN      11280/ispconfig_htt
    What can I do to make sure that ISPConfig is using the correct username/password/database name to communicate with mysql? Is there something else that is more likely to be the problem?
    Thanks in advance!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess you entered the wrong hostname for the mysql server during setup. Please change the mysql hostanme to "localhost" in the file /home/admispconfig/ispconfig/lib/config.inc.php
     
  3. catdude

    catdude ISPConfig Developer ISPConfig Developer

    I'd recommend taking a look inside /home/admispconfig/ispconfig/lib/config.inc.php to see that the proper values are specified for the database. Specifically, you might want to look at:
    $go_info["server"]["db_host"]
    $go_info["server"]["db_name"]
    $go_info["server"]["db_user"]
    $go_info["server"]["db_password"]
    $go_info["server"]["db_type"]
     
  4. jasmith86

    jasmith86 New Member

    Thanks! I just changed the settings in that file and everything seems to be working now.
     

Share This Page