MySQL User not creating / updating

Discussion in 'ISPConfig 3 Priority Support' started by cajdavidson, Apr 17, 2019.

  1. cajdavidson

    cajdavidson New Member HowtoForge Supporter

    Following on from the issue created in the wrong location (now closed) - https://git.ispconfig.org/ispconfig/ispconfig3/issues/5294

    As requested - "Check that you have the correct MySQL root password in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf"

    The MySQL password in here is correct, to be able to login to the local MySQL server on which the issue is apparent, any further suggestions?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which MySQL or MariaDB version do you have installed? You can check that with the command:

    mysql --version
     
  3. cajdavidson

    cajdavidson New Member HowtoForge Supporter

    mysql Ver 15.1 Distrib 10.1.38-MariaDB, for debian-linux-gnu (x86_64) using readline 5.2
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    That's ok. And the mysql user mentioned in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf is the user 'root' and not a different user?
     
  5. cajdavidson

    cajdavidson New Member HowtoForge Supporter

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    And just to mention it, you created database too, right? MySQL users get created when you add the database and not when you create a mysql user in ispconfig. The reason for that is that mysql users are not bound to a specific server, so that ispconfig does not know on which server the user needs to be added unless you add a database which actually uses this user. And a user without being able to access anything makes no sense anyway.
     
  7. cajdavidson

    cajdavidson New Member HowtoForge Supporter

    Yes there is a database created for this user, and associated within ISPConfig, marked as active and seems to be setup correctly to me.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Really strange, I tested it here again with current git-stable, just to be sure, and it works fine. I'm using Ubuntu 18.04 and the same MariaDB version that you are using.

    Please try to create a new database user and then a new database, wait a minute and check in phpmyadmin if the user was created. Just to ensure that it is reproducible on your system. And please check in phpmyadmin if the root user in the mysql.user table has all privileges incl. the privileges to create users and the grant privilege etc. and in case there is more than one root user, check if all root users have all privileges.
     
  9. cajdavidson

    cajdavidson New Member HowtoForge Supporter

    Yes, so the user seems to be created correctly when trying with a new test site, let me do some more digging about how this user was initially created from my colleague and get back to you.
     

Share This Page