mysql tmp table size 33,554,432

Discussion in 'Server Operation' started by White, Aug 15, 2010.

  1. White

    White Member

    Im trying to install flashchat and i have run into a problem i havent found a fix for yet.

    the install is failing as it is saying it has run out of memory and the temp table from the phpmyadmin variables is the only thing that has the right memory size left to change.

    ERROR:
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 35 bytes) in /var/www/www.mysite.com/init.php on line 333

    ive looked in /etc/mysql/my.cnf but i cant find a variable to increase, does anyone know how i can increase this from 32M to 64M to try, i know 35bytes should not blow 32M
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You must increase the memory in your php.ini and then restart Apache.
     
  3. White

    White Member

    Thanks Falko for the reply,

    i have done as you said and changed the settings in

    /etc/php5/apache2/php.ini

    and in

    /etc/php5/cli/php.ini

    and restarted apache2 but the phpmyadmin variables and settings table still shows

    tmp table size 33,554,432

    i cant find a setting for this to change in either php.ini file
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the exact error message now? What exactly did you change?
     
  5. White

    White Member

    The error is the same

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 35 bytes) in /var/www/www.mysite.com/init.php on line 333

    The only matching bytes size for this error is

    tmp table size 33,554,432

    from my phpmyadmin

    Show MySQL system variables Documentation

    I have changed the size of alot of figures in php.ini generally by a factor of 2 i.e. timeout 60 to 120 and 32M to 64M 8M to 16M etc etc but although these show up in the MySQL variables the tmp table size remains at 33M i have also analysed and optimised my tables and im at a loss im afraid.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you post a screenshot of phpMyAdmin showing this variable?
     
  7. White

    White Member

    Falko it can be found here on the mysql home page

    mysqlhome.jpg



    here you can see the tmp table size

    mysqlsystemvariables.jpg
     
  8. falko

    falko Super Moderator ISPConfig Developer

  9. White

    White Member

    Thanks Falko, added 2 extra lines and increased those tables and it worked.

    the 2 lines i added were

    tmp_table_size = 100M
    max_heap_table_size = 100M
     

Share This Page