mysql root login

Discussion in 'Server Operation' started by cwtudor, Apr 5, 2013.

  1. cwtudor

    cwtudor New Member

    unable to login as root, mysql seems to be running fine. I can login to a database just not as root.

    root@shv:~# mysql -u root -p
    Enter password:
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)


    Try to stop mysql so I could start in safe mode with no luck. I get this

    root@shv:~# /etc/init.d/mysql stop
    Stopping MySQL database server: mysqld failed!.


    what does daemon.error mean here

    root@shv:~# ps ax | grep mysql
    719 ? Sl 0:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/run/mysqld/mysqld.sock --port=3306
    720 ? S 0:00 logger -t mysqld -p daemon.error
    805 pts/0 S+ 0:00 grep mysql
    1442 ? S 0:00 /bin/sh /usr/bin/mysqld_safe

    this should be my password.
    root@shv:~# cat /usr/local/ispconfig/server/lib/mysql_clientdb.conf
    <?php

    $clientdb_host = 'localhost';
    $clientdb_user = 'root';
    $clientdb_password = 'imhotep';

    ?>

    can not login as admin it ISP Config now either. HELP Please
     
  2. darinpeterson

    darinpeterson Member HowtoForge Supporter

  3. cwtudor

    cwtudor New Member

    can not log in as root

    Sorry none of the suggestions worked. Can not log in as root and can not stop mysql service.
     
  4. cwtudor

    cwtudor New Member

    Thanks got it fixed

    Thanks for all the help. I was able to fix the problem this morning. Using pkill -p mysql I was able to stop mysql. I was afraid to try this before because I did not want to lose any data, but it worked without any loss. So Thanks for answer Darin.
     
  5. darinpeterson

    darinpeterson Member HowtoForge Supporter

    Sure. Glad it worked for you...

    Regards,
    Darin
     

Share This Page