mysql replication error

Discussion in 'Installation/Configuration' started by tburge, Oct 22, 2013.

  1. tburge

    tburge New Member

    So I am getting this error in the monitor.

    Replication failed. Error: (web_domain) in MySQL server: (localhost) Unknown column 'last_quota_notification' in 'field list' # SQL: REPLACE INTO web_domain (`domain_id`,`sys_userid`,`sys_groupid`,`sys_perm_user`,`sys_perm_group`,`sys_perm_other`,`server_id`,`ip_address`,`ipv6_address`,`domain`,`type`,`parent_domain_id`,`vhost_type`,`document_root`,`web_folder`,`system_user`,`system_group`,`hd_quota`,`traffic_quota`,`cgi`,`ssi`,`suexec`,`errordocs`,`is_subdomainwww`,`subdomain`,`php`,`ruby`,`python`,`perl`,`redirect_type`,`redirect_path`,`seo_redirect`,`ssl`,`ssl_state`,`ssl_locality`,`ssl_organisation`,`ssl_organisation_unit`,`ssl_country`,`ssl_domain`,`ssl_request`,`ssl_cert`,`ssl_bundle`,`ssl_key`,`ssl_action`,`stats_password`,`stats_type`,`allow_override`,`apache_directives`,`nginx_directives`,`php_fpm_use_socket`,`pm`,`pm_max_children`,`pm_start_servers`,`pm_min_spare_servers`,`pm_max_spare_servers`,`pm_process_idle_timeout`,`pm_max_requests`,`php_open_basedir`,`custom_php_ini`,`backup_interval`,`backup_copies`,`active`,`traffic_quota_lock`,`fastcgi_php_version`,`proxy_directives`,`last_quota_notification`,`rewrite_rules`) VALUES ('7','7','6','riud','riud','','2','*','','www.trinityarchitecturalrailing.com','vhost','0','name','/var/www/clients/client5/web7','','web7','client5','-1','-1','n','n','y','0','1','www','fast-cgi','n','n','n','','','','','','','','','','','','','','','','','webalizer','All','','','n','dynamic','10','2','1','5','10','0','/var/www/clients/client5/web7/web:/var/www/clients/client5/web7/private:/var/www/clients/client5/web7/tmp:/var/www/www.trinityarchitecturalrailing.com/web:/srv/www/www.trinityarchitecturalrailing.com/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php','','none','1','y','n','','','','')

    The problem I was having is that pure-ftpd wasn't seeing users that I created on the master ispconfig server. So I changed the pure-ftpd mysql.conf to point to the master server so it I could authenticate ftp users. Now I'm getting the above error and I am not sure why. They could be unrelated, but I am not sure.

    Any suggestions?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Ensure that the ispconfig version on the slave is identical to the one of the master. If replication stopped like in your case, ftp logins of new users eill not work as well. So yes, both problems have the same source.
     
  3. tburge

    tburge New Member

    Seems like it was different versions. I have tried to update it before but apparently it didnt take because there was dns resolution issues so it wasn't syncing right. Finally got the distro updated and ispconfig. After a reboot, everything is good to go. Thanks!
     

Share This Page