MySQL related Installation Problem

Discussion in 'Installation/Configuration' started by crn_admin, Aug 8, 2006.

  1. crn_admin

    crn_admin New Member

    Hello all,

    I have run into a stumbling block in my installation of ISPConfig and I am hoping somebody can help.

    I have done everything as described in "The Perfect Setup" guide for SUSE.... the only complication being that I am running SUSE 10.0, not 9.3. However, all seemed to be going exactly according to plan until I attempted to install ISPConfig itself. The entire installation seems to run normally, but the last bit of output from the compilation indicated there was a problem:

    /root/ispconfig/httpd/bin/apachectl startssl: httpd started
    Could not connect to MySQL server!FreshClam is already running!
    ISPConfig system is now up and running!

    When I try to log into ISPConfig via browser, I get this:

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

    Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60

    I am not sure what the problem is. MySQL is up and running and I am able to log into it.... I am even able to log in remotely. One odd thing seems to be that, while the database for ISPConfig is created in MySQL, there are no tables in it... a completely empty schema.

    Any help would be greatly appreciated!

    Sean
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Does your MySQL root password contain uncommon characters? That is most likely the problem.
     
  3. crn_admin

    crn_admin New Member

    By uncommon, do you mean non-alphanumeric? The root pw does contain '@' and '$'.
     
  4. crn_admin

    crn_admin New Member

    I changed the MySQL root pw to contain only alpha-numeric characters and re-installed. This time, I got the following output at the end of the install process:

    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!FreshClam is already running!
    ISPConfig system is now up and running!

    Again, the database has been created, but there are no tables in the schema. When I attempt to log in to ISPConfig through the web interface, I get the message that the password (admin) is invalid.

    Any thoughts?
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Did you delete the old ISPConfig before you did this? Otherwise the installer performs an update, and if your database was empty before, it willl be empty after the update...
     
  6. crn_admin

    crn_admin New Member

    That did the trick... thanks a lot!
     

Share This Page