mysql problem

Discussion in 'HOWTO-Related Questions' started by golan, Jun 13, 2009.

  1. golan

    golan New Member

    My server crashed a few days a go and it did not accept the root password i did single mode and reset password and then i could loging as root but network did not worked.
    now when ever i run an application i am receiving ls -la /var/lib/
    Segmentation fault.
    Add/remove software is not working and give me "Unable to tetrieve softwrare information"
    MySQL server is not working and i am receiving this error.
    when i try to restart mysql i am receiving this error:
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111)

    any help apprecaited.
    Last edited: Jun 13, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    Seems as if there's something wrong with /var/lib/. What are the outputs of
    df -h
    ? What's in /etc/fstab?
  3. golan

    golan New Member

    Hi Falko,
    here is the output for mount:
    /dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    devpts on /dev/pts type devpts (rw,gid=5,mode=620)
    /dev/sda1 on /boot type ext3 (rw)
    tmpfs on /dev/shm type tmpfs (rw)
    none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)

    and the output for df -h:
    Filesystem Size Used Avail Use% Mounted on
    71G 8.3G 59G 13% /
    /dev/sda1 99M 28M 66M 30% /boot

    the fstab has these lines:
    /dev/VolGroup00/LogVol00 / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    devpts /dev/pts devpts gid=5,mode=620 0 0
    tmpfs /dev/shm tmpfs defaults 0 0
    proc /proc proc defaults 0 0
    sysfs /sys sysfs defaults 0 0
    /dev/VolGroup00/LogVol01 swap swap defaults 0 0
    /dev/sdb1 /mnt/cle vfat noauto,users,noexec,rw,uid=1000,gid=1000 0 0

    By the way our websites are down too.

    Last edited: Jun 14, 2009
  4. falko

    falko Super Moderator ISPConfig Developer

    I think you should run a filesystem check on / with fsck.ext3. You probably have to boot into a rescue system to do so.
  5. golan

    golan New Member

    Hi Falko,
    would you please explain a bit more what command should i run? and how can i boot into a rescue system?

  6. falko

    falko Super Moderator ISPConfig Developer

Share This Page