MySQL problem on install

Discussion in 'Installation/Configuration' started by badben, Oct 15, 2005.

  1. badben

    badben ISPConfig Developer

    The install keeps stopping just after choosing the installation mode.

    It says that MySQl is not started and stops.

    However just before I started the setup process I started all the programs including mysql.

    I did notice though that mysql started fine using /etc/init.d/mysqld start
    though restart would not work using /etc/init.d/mysqld resart
    .. it would stop but not start - it timed out.
    I could start it again using /etc/init.d/mysqld start though.

    What could be the problem?

    I am using Mandrake and followed the setup instructions for the perfect setup.

    Ben
     
  2. themachine

    themachine HowtoForge Supporter

    Errors and Logs?

    Can you actually verify that mysql is running?

    # ps aux | grep mysql


    Can you connect to the mysql server? (might be able to just use 'mysql' without any flags if you haven't set a root password)

    # host01:/# mysql -u root -p
    Enter password:
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 1360 to server version: 4.0.24_Debian-10sarge1-log

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

    mysql>


    If not, then I'd check the log files. I'm not familiar with mandrake, but standard places would be /var/log/messages, /var/log/syslog, /var/log/mysql.err, /var/log/mysql.log, /var/log/mysql/*, etc.

    see if there are any entries related to mysql after starting it, stopping it, restarting it ... what have you.

    If you find any errors please post them.
     
  3. badben

    badben ISPConfig Developer

    This is what I got when I tried

    # ps aux | grep mysql

    What does that mean?

    [root@tidy-hosting install_ispconfig]# ps aux | grep mysql
    root 10351 0.0 0.4 2184 1140 ? S 16:04 0:00 /bin/sh /usr/bin/mysqld_safe --defaults-file=/etc/my.cnf --skip-networking --pid-file=/var/run/mysqld/mysqld.pid
    mysql 10389 0.2 6.7 65696 17596 ? S 16:04 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking
    mysql 10393 0.0 6.7 65696 17596 ? S 16:04 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking
    mysql 10394 0.0 6.7 65696 17596 ? S 16:04 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking
    mysql 10395 0.0 6.7 65696 17596 ? S 16:04 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking
    mysql 10396 0.0 6.7 65696 17596 ? S 16:04 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking
    mysql 10397 0.0 6.7 65696 17596 ? S 16:04 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking
    mysql 10398 0.0 6.7 65696 17596 ? S 16:04 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking
    mysql 10399 0.0 6.7 65696 17596 ? S 16:04 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking
    mysql 10400 0.0 6.7 65696 17596 ? S 16:04 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking
    mysql 10401 0.0 6.7 65696 17596 ? S 16:04 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking
    mysql 10402 0.0 6.7 65696 17596 ? S 16:04 0:00 /usr/sbin/mysqld --defaults-file=/etc/my.cnf --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock --skip-networking
    root 10940 0.0 0.1 1648 488 pts/3 R+ 16:05 0:00 grep mysql
     
  4. badben

    badben ISPConfig Developer

    when I try to run mysql with

    mysql -u root -p

    everything seems ok and it lets me in.

    Ben
     
  5. till

    till Super Moderator

    Have you removed skip-networking in the mysql configuration file (my.cnf) and then restarted mysql?
     
  6. badben

    badben ISPConfig Developer

    Where is the file my.cnf?

    I appologise for my ignorance.

    I am a very novice linux user (i.e. I have no experience except for yesterday and today whatsoever in linux)
     
  7. badben

    badben ISPConfig Developer

    ... and how do I remove skip-networking? ( I have found my.cnf)

    There is no mention of skip-networking in the file when I looked at it.

    thanks ben
     
    Last edited: Oct 15, 2005
  8. till

    till Super Moderator

  9. badben

    badben ISPConfig Developer

    oops.

    Thanks

    my bad

    ben
     
  10. Deepthi

    Deepthi New Member

    Internal Server Error

    Ive installed Mysql and PERL in RHEL3 and while working with the Mozilla browser im getting this error message.
    Even ive started service of mysqld and httpd........ They are working well.I've written my perl scripts in cgi-bin but im still getting this error.

    "The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Apache/2.0.46 (Red Hat) Server at 127.0.0.1 Port 80"

    Can anyone please help me? ill be thankful to you..........
     
  11. falko

    falko Super Moderator

    Did you try the test scripts from http://www.howtoforge.com/forums/showthread.php?t=171?

    Did you make your Perl scripts executable (chmod 755 or something like that)? Did you save the scripts with Unix linebreaks (you'll get errors when you saved them with Windows linebreaks).
     
  12. Deepthi

    Deepthi New Member

    Thanks for giving me the reply.But its not the problem im having........
    i've given the permissions to my PERL scripts.I can run my PERL scripts on Mozilla browser but in unable to run my HTML pages... Why i donno.Evn ive saved the HTML scripts in the same folder..... /var/www/cgi-bin
    and the path is http://localhost:80/cgi-bin/login.pl is working well
    but http://localhost:80/cgi-bin/login.html is not working.
    I'm gettting the following error message.....

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    More information about this error may be available in the server error log.
    Apache/2.0.46 (Red Hat) Server at 127.0.0.1 Port 80


    can you please help me in this.......
    Thank you
    Deepthi
     
  13. falko

    falko Super Moderator

Share This Page