mysql password perfect debian etch howto

Discussion in 'HOWTO-Related Questions' started by gdowrey, Sep 23, 2007.

  1. gdowrey

    gdowrey New Member

    In following howto for mysql set up I keep getting the following error message. Here are the instructions:


    mysqladmin -u root password yourrootsqlpassword
    mysqladmin -h -u root password yourrootsqlpassword

    to set a password for the user root (otherwise anybody can access your MySQL database!).

    Here is the error message:

    ddmzserver:~# mysqladmin -u root password xxxxxxxx
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you get this error message, there is already a password set on your mysql server or your mysql server does not listen on localhost or is not started.
  3. edge

    edge Active Member Moderator

    Some time ago (long time) I had something similar like this I think.

    The problem (in my case) was that I was missing the setting localhost in my /etc/hosts file.

    Have a look at your ]/etc/hosts file, and see if you have that setting.
    An easy test would be to see if you can ping "localhost" from the server itself.

Share This Page