mysql not working

Discussion in 'Server Operation' started by dmgeurts, Nov 6, 2005.

  1. dmgeurts

    dmgeurts Member

    Right I got my php and vhost thingy worked out then I find that info.php states that it hasn't got mysql while php4-mysql is installed and the site has it turned on in ispconfig. Any way I can troubleshoot this?

    www.djerk.nl/info.php

    '--without-mysql'


    Should php.ini have mysql off globally? ";extension=mysql.so"

    TIA
     
    Last edited: Nov 6, 2005
  2. till

    till Super Moderator

    This should not be commented out:

    ";extension=mysql.so"

    When you have the mysql php extension installed. Try to remove the comment (;" and restart your apache webserver.
     
  3. dmgeurts

    dmgeurts Member

    So unlike PHP which disabled by default and enabled per vhost, how is mysql denied per vhost then?

    I did uncomment the line so I could install my site :eek:) just wondering if it's the way it should be...
     
  4. falko

    falko Super Moderator

    You have a check box in ISPConfig where you can enable/disable MySQL.
     

Share This Page