MySQL listen all interfaces [ISPConfig 3]

Discussion in 'Installation/Configuration' started by sighkick, Feb 28, 2009.

  1. sighkick

    sighkick New Member

    The Perfect Server - Debian Lenny (Debian 5.0) [ISPConfig 3] - Page 3

    vi /etc/mysql/my.cnf - the lines containing:

    [...]
    # Instead of skip-networking the default is now to listen only on
    # localhost which is more compatible and is not less secure.
    #bind-address = 127.0.0.1
    [...]

    Are not included in the file: - Am I doing something wrong?

    #
    # The MySQL database server configuration file.
    #
    # You can copy this to one of:
    # - "/etc/mysql/my.cnf" to set global options,
    # - "~/.my.cnf" to set user-specific options.
    #
    # One can use all long options that the program supports.
    # Run program with --help to get a list of available options and with
    # --print-defaults to see which it would actually understand and use.
    #
    # For explanations see
    # http://dev.mysql.com/doc/mysql/en/server-system-variables.html

    # This will be passed to all mysql clients
    # It has been reported that passwords should be enclosed with ticks/quotes
    # escpecially if they contain "#" chars...
    # Remember to edit /etc/mysql/debian.cnf when changing the socket location.
    [client]
    port = 3306
    socket = /var/run/mysqld/mysqld.sock

    # Here is entries for some specific programs
    # The following values assume you have at least 32M ram

    # This was formally known as [safe_mysqld]. Both versions are currently parsed.
    [mysqld_safe]
    socket = /var/run/mysqld/mysqld.sock
    nice = 0

    [mysqld]
    #
    # * Basic Settings
    "/etc/mysql/my.cnf" 143L, 3865C 1,1 Top

    I now get

    zeus:~# netstat -tap | grep mysql
    tcp 0 0 localhost.localdo:mysql *:* LISTEN 16563/mysqld

    Which is not what the Howto suggests.

    How do I edit out the localhost so that MySQL listens on all ports?
     
    Last edited: Feb 28, 2009
  2. till

    till Super Moderator

    And you are really sure that you are using debian etch?

    Please post the output of:

    grep bind-address /etc/mysql/my.cnf
     
  3. sighkick

    sighkick New Member

    Debian Etch? - This thread is Debian Lenny ?

    Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
    permitted by applicable law.
    Last login: Sat Feb 28 12:12:11 2009 from 192.168.1.99
    zeus:~# grep bind-address /etc/mysql/my.cnf
    bind-address = 127.0.0.1


    Bind address is clearly localhost and not ALL as suggested in the Howto.

    p.s. I try to follow the Howto word-for-word so I suppose I can be considered a beta tester of the instructions.

    I am definitely NOT using ETCH - can you help to bind to ALL please?
     
  4. till

    till Super Moderator

    You have to comment out the line as the tutorial describes, so find the line:

    bind-address = 127.0.0.1

    and change it to:

    # bind-address = 127.0.0.1

    and then restart mysql.
     
  5. sighkick

    sighkick New Member

    Thanks Till but.........

    As stated above, I have printed out my.cnf and

    It does not contain the line bind-address = 127.0.0.1 so it becomes rather difficult to comment out a line that is not there!

    I will have a look again before I revert to ISPConfig 2 - as you suggested in another thread, ISPConfig3 is not fully finished yet and there is no indication when it may be stable.
     
  6. till

    till Super Moderator

    Take a look at post #3 and you see that you already confirmed that it contains the line ;) So take a closer look at it and change it!

    You have to find and change the exact same line for ispconfig 2 as well, so that makes no difference.
     

Share This Page