MySQL issue during install of ISPConfig

Discussion in 'Installation/Configuration' started by ricbax, Sep 8, 2005.

  1. ricbax

    ricbax New Member

    Can someone please help me with this problem?

    Preparing files. Please wait a moment...
    All prerequisites are fulfilled.
    Here we go...
    Please enter your MySQL server:localhost
    Please enter your MySQL user:root
    Please enter your MySQL password:my password went here
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
    ERROR: The provided MySQL password is wrong! The installation routine stops here!
    You have new mail in /var/spool/mail/root

    The weird thing is ... when I enter my password from the command line

    [root@server1]# mysql -uroot -pXXXXXX

    I get the mysql prompt

    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 13 to server version: 4.1.12

    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

    mysql>

    Any ideas? :confused:
     
  2. till

    till Super Moderator

    Do you have any special charackters in your mySQL password? The installers seems to have problems with that sometimes. Another thind, have you disabled "skip-networking" in your mysql configuration? ISPCOnfig has to connect trough tcp sockets on localhost.
     
  3. ricbax

    ricbax New Member

    I figured out the problem and it was human error :rolleyes:
     
  4. dranieri

    dranieri New Member

    MySql password error


    I have checked everything and verified my MySQL password and user....it is giving me the same error message....I don't know what else to do.....please help me.
     
  5. till

    till Super Moderator

    please post the output of this command to the forum:

    Code:
    netstat -tap | grep mysql
    Does your mySQL password contains any special chars (other than a-z A-Z 0-9 _)?
     

Share This Page