MySQL is not enabled in PHP Configure

Discussion in 'Installation/Configuration' started by kong121s, May 18, 2006.

  1. kong121s

    kong121s New Member

    I can't use mysql_connect in php page.
    then I run test.php that contain this code
    <? phpinfo(); ?>
    It appears many table.
    in Configure Command row. It show this
    ./configure' '--build=x86_64-redhat-linux' '--host=x86_64-redhat-linux' 
    '--target=x86_64-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' 
    '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' 
    '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib64' 
    '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' 
    '--mandir=/usr/share/man' '--infodir=/usr/share/info' 
    '--cache-file=../config.cache' '--with-libdir=lib64' 
    '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' 
    '--disable-debug' '--with-pic' '--disable-rpath' '--without-pear' '--with-bz2' 
    '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' 
    '--with-png-dir=/usr' '--enable-gd-native-ttf' '--without-gdbm' 
    '--with-gettext' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' 
    '--with-openssl' '--with-png' '--with-pspell' '--with-expat-dir=/usr' 
    '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-exif' 
    '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' 
    '--enable-sysvshm' '--enable-sysvmsg' '--enable-track-vars' 
    '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-kerberos' 
    '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' 
    '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' 
    '--enable-dio' '--with-mime-magic=/etc/httpd/conf/magic' '--without-sqlite' 
    '--with-libxml-dir=/usr' '--with-xml' '--with-apxs2=/usr/sbin/apxs' 
    [B]'--without-mysql'[/B] '--without-gd' '--without-odbc' '--disable-dom' 
    '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader'
    How to fix this. I know it is my mistake on Fedoro core5 installation.
    but I don't want to reinstall all.
    Thank you
    Last edited: May 18, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Just install the php-mysql package from fedora to get mySQL support.
  3. kong121s

    kong121s New Member

    I tried to run "yum install php-mysql" , but not work.

    But now, I run this command.
    "yum install php php-devel php-gd php-imap php-ldap php-mysql php-odbc
    php-pear php-xml php-xmlrpc curl curl-devel perl-libwww-perl ImageMagick
    libxml2 libxml2-devel"
    It already work. :)

    But result of test.php didn't change?? :confused:
    Does "--without-mysql" mean I can't use mysql??
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, it just means MYSQL is not compiled in. This is OK for most linux distributioons incl. fedora.

    Please check your phpinfo output, if there is a mysql section. You can also try to restart your apache webserver.
  5. kong121s

    kong121s New Member

    thank, till.

Share This Page