MySQL installing problem

Discussion in 'Server Operation' started by n!x, Nov 23, 2005.

  1. n!x

    n!x New Member

    I'm following this guide (which is great stuff), but I'm having a problem with the MySQL section.

    When I run "netstat -tap" I see this line:

    Code:
    tcp        0      0 *:mysql                 *:*                     LISTEN     -
    I don't get the "2449/mysqld" as the last thing, but only a "-".
    My "skip-networking" thing in "/etc/mysql/my.cnf" i commented out and MySQL restartet - but the same thing is in "netstat -tap".

    Anyone has a suggestion?
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Thats OK, if you dont encounter any other problems.

    Till
     
  3. n!x

    n!x New Member

    Ok, but shouldn't MySQL listen on a specific port?
     
  4. n!x

    n!x New Member

    Ok, now I get another problem.

    When I try this:

    Code:
    sudo echo 'pwcheck_method: saslauthd' >> /etc/postfix/sasl/smtpd.conf
    
    I get a:

    Code:
    -bash: /etc/postfix/sasl/smtpd.conf: Permission denied
    
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Dont use sudo, you must login as root user! All steps in the howto must be done as root user.
     
  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    MySQL listens on a specific port:

    *:mysql

    means that it listens on all available IP's on the mysql port.
     
  7. n!x

    n!x New Member

    Ok thanks till!!

    I now ran into trouble again.

    When I run the "telnet localhost 25" it only shows:

    Code:
    Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    220 server.example.com ESMTP Postfix (Ubuntu)
    
    And nothing more happens..... It times out.

    Anyone? I really need help...

    /n!x
     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Have you entered:

    ehlo localhost

    and hit return?

     

Share This Page