MySql error 1044 (fedora 11)

Discussion in 'Installation/Configuration' started by Pashy, Jun 7, 2010.

  1. Pashy

    Pashy New Member

    Hi folks,
    I am installing MySql on Linux (Fedora core 11). Basically I am newbie & wana create a PHP application. I am done with PHP & Apache installation.
    I am facing some serious problems while Installing Mysql.
    below are all the tried codes & the outputs/errors:
    #yum install mysql mysql-server
    #chkconfig --levels 235 mysqld on
    #/etc/init.d/mysqld start
    #mysqladmin -u root password yourrootsqlpassword

    in my case which exactly looks like
    # mysqladmin -u root 'root_password' 'newroot_password'
    the output is
    mysqladmin: connect to server at 'localhost' failed
    error: 'Access denied for user 'root'@'localhost' (using password: NO)'

    Here I am confused abt the root password, as to what password exactly I have to enter here. Since I had never set a password for Mysql as far as I remember. I had removed & reinstalled the MySql packages.
    Then I even tried:
    #mysql -u root -p
    Enter password:
    ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

    Folks I have tried all possibilities that were mentioned on the Internet & various forums.
    Can anyone kindly help me out with the detailed & easliy understandable steps
    e.g if the command is :
    # mysqladmin -u root password new-password
    then what actually I have to enter after root "word password" or "actual_password"
    Hope I am able to convey my doubt properly.

    However I am able to get into the Mysql prompt with the below code:
    #mysql -user=root
    but not able to execute the commands like:
    mysql> create database salesdata;
    ERROR 1044 (42000): Access denied for user ''@'localhost' to database 'salesdata'

    Can anyone plz reply to this on priority.

    Thanks in advance..!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Pashy

    Pashy New Member

    Hey Till,

    You are a super genius, after trying for hours long I couldn't
    fix the problem but your reply solved it in 1 min..

    Except the location of MySql daemon everything was perfect in your
    i.e. /etc/rc.d/init.d/mysqld start

    Thanks a Ton..
  4. Pashy

    Pashy New Member

    Mysql error --skip-grant-tables

    Hi Till,

    Thank you.

    But I am facing a problem after skipping the grant-tables as instructed in your reply.
    Code :
    mysqld_safe --skip-grant-tables &

    I have created a Database "hello" and I am trying to give some privileges to user 'pashy'.
    mysql> grant all privileges on hello.* to [email protected]"TestServer" identified by 'Pashy';
    ERROR 1290 (HY000): The MySQL server is running with the --skip-grant-tables option so it cannot execute this statement

    please kindly help..
  5. falko

    falko Super Moderator ISPConfig Developer

Share This Page