MySQL dont start!

Discussion in 'Installation/Configuration' started by Captain, Mar 5, 2010.

  1. Captain

    Captain Member

    Hello!

    After update from Ubuntu 9.04 to 9.10 MYSQL Server want not start!!!


    Please HELP ME!

    It is LOG:
    Code:
    Mar  5 21:48:18 itex mysqld: 100305 21:48:18 [Note] Plugin 'FEDERATED' is disabled.
    Mar  5 21:48:18 itex mysqld: /usr/sbin/mysqld: Table 'mysql.plugin' doesn't exist
    Mar  5 21:48:18 itex mysqld: 100305 21:48:18 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
    Mar  5 21:48:18 itex mysqld: 100305 21:48:18  InnoDB: Started; log sequence number 0 454701
    Mar  5 21:48:18 itex mysqld: 100305 21:48:18 [ERROR] /usr/sbin/mysqld: unknown option '--skip-bdb'
    Mar  5 21:48:18 itex mysqld: 100305 21:48:18 [ERROR] Aborting
    Mar  5 21:48:18 itex mysqld:
    Mar  5 21:48:18 itex mysqld: 100305 21:48:18  InnoDB: Starting shutdown...
    Mar  5 21:48:19 itex mysqld: 100305 21:48:19  InnoDB: Shutdown completed; log sequence number 0 454701
    Mar  5 21:48:19 itex mysqld: 100305 21:48:19 [Warning] Forcing shutdown of 1 plugins
    Mar  5 21:48:19 itex mysqld: 100305 21:48:19 [Note] /usr/sbin/mysqld: Shutdown complete
    Mar  5 21:48:19 itex mysqld:
    Mar  5 21:48:19 itex mysqld_safe: mysqld from pid file /var/run/mysqld/mysqld.pid ended
    Mar  5 21:48:32 itex /etc/init.d/mysql[4027]: 0 processes alive and '/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping' resulted in
    Mar  5 21:48:32 itex /etc/init.d/mysql[4027]: #007/usr/bin/mysqladmin: connect to server at 'localhost' failed
    Mar  5 21:48:32 itex /etc/init.d/mysql[4027]: error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'
    Mar  5 21:48:32 itex /etc/init.d/mysql[4027]: Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
    Mar  5 21:48:32 itex /etc/init.d/mysql[4027]:
    
    
     
  2. jnsc

    jnsc rotaredoM Moderator

    the error message seems clear for me, and it give you the solution.
     
  3. Captain

    Captain Member

    I tried mysqlcheck:

    Code:
    [email protected]:~# mysql_upgrade
    Looking for 'mysql' as: mysql
    Looking for 'mysqlcheck' as: mysqlcheck
    Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysqld/mysqld.sock'
    mysqlcheck: Got error: 2002: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2) when trying to connect
    FATAL ERROR: Upgrade failed
    
     
  4. jnsc

    jnsc rotaredoM Moderator

    Ok, there is also this error
    Have a look at your /etc/my.cnf file and search for skip-bdb
     
  5. Captain

    Captain Member

    Big Big Thnks Man!
    You safed me!
     
  6. jnsc

    jnsc rotaredoM Moderator

    No problem, don't forget to also run mysql_upgrade, as there was also an error for it.
     
  7. Captain

    Captain Member

    MySQL server works great.

    But when i try to mysql_upgrade:

    Code:
    [email protected]:~# mysql_upgrade
    Looking for 'mysql' as: mysql
    Looking for 'mysqlcheck' as: mysqlcheck
    Running 'mysqlcheck' with connection arguments: '--port=3306' '--socket=/var/run/mysqld/mysqld.sock'
    mysqlcheck: Got error: 1045: Access denied for user 'root'@'localhost' (using password: NO) when trying to connect
    FATAL ERROR: Upgrade failed
    
    It is normal?
     
  8. jnsc

    jnsc rotaredoM Moderator

    yes it's normal, if you have set a password for the MySQL root account (which is greatly recommended) you have to use the -p flag to be prompted for a password.
     

Share This Page