MySQL connection problem

Discussion in 'Installation/Configuration' started by cartdev, Oct 3, 2005.

  1. cartdev

    cartdev New Member

    I had problems with MySQL I think because I used some unusual carachters in my root password. Now I've changed the pass both in MySQL and in the /home/admispconfig/ispconfig/lib/config.inc.php. I can login to the MySQL monitor within the ispconfigdb at the command line, but when I attempt to access the web page, I get the login screen but it says "ERROR 101: wrong username or password." when I use admin and admin. It appears that ispconfig is not even hitting the database or if it is, that the admin:admin record is missing.

    Also, it is a pain to go through the install so many times. Can you save it at anypoint to start over? Just not having to type the cert stuff would be helpful.
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I guess that at least the admin user record is missing, if not the whole ISPConfig database. Do you have a phpMyAdmin where you can check that?

    No, you have to run the whole installation again. Delete the directories /home/admispconfig and /root/ispconfig before and also the ISPConfig database if there is one...
     
  3. cartdev

    cartdev New Member

    Thanks for the help. Know that I have succeeded in getting this up on another box, but it took some fiddling. Now I'm trying to make an exact recipe for putting this on several boxes.

    On a whim, I reinstalled things again, despite the fact that the last install completed. This time, I got this error:

    HTML:
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
    No results found!FreshClam is already running!
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    
    I get the exact same login problem on the website, i.e. "ERROR 101: wrong username or password."

    Oh, I just checked the ispconfig database and it doesn't have any tables. WHat can I do to build this db properly?

    Bob
     
    Last edited: Oct 3, 2005
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Delete the current ISPConfig installation and install again.
     
  5. cartdev

    cartdev New Member

    I just did delete the install and both directores /root/isp... and /home/admin...
    and the above is what I reported. A db was created, but without tables. Reinstalling yet again, won't change anything. How can I create the tables?

    mysql> select * from isp_server;
    ERROR 1146 (42S02): Table 'ispconfigdb.isp_server' doesn't exist
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You can only create them using the installer because some entries are created on-the-fly.
    Before you install ISPConfig please delete the whole ispconfig database, not only the tables in it!
     
  7. cartdev

    cartdev New Member

    Dropping the empty ispconfig db prior to reinstall did the trick. Thank you!
     
  8. cartdev

    cartdev New Member

    Wierd. I stopped for lunch, returned and the session expired. WHen I tried to log back in, I get the "ERROR 101: wrong username or password." The database has tables. I restarted ISPConfig and that didn't help. What's up with this? Any clues?

    By the way, there is an admin record in the table sys_users.
     
    Last edited: Oct 3, 2005
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Maybe a typo?
     
  10. zer0_g666

    zer0_g666 ISPConfig Developer ISPConfig Developer


    Ive had the same problem .... ive tried dropping the database and then creating a new one prior to install and still getting the same problem, can any one suggest anything that might help ? :/
     
  11. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The ISPConfig installer creates a database itself. Dont create the database manually! If the database exists, the installer will fail.
     
  12. zer0_g666

    zer0_g666 ISPConfig Developer ISPConfig Developer

    Ah, that fixed that problem ... after installing it to wards the end it says

    'no such file in: /etc/apache2/vhost.d/*.conf'

    and when i create sites and try them in my browser they dnt work ... :(
     
  13. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Did you get an error when you execute:

    httpd -t
     
  14. zer0_g666

    zer0_g666 ISPConfig Developer ISPConfig Developer

    nope ... i got sytax ok ...

    *sigh*

    looks like im gonna have to re-install it ... again ....
     
  15. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No... We have a few more options to figure out whats wrong :)

    Please have a look in the ISPConfig logfile:

    /home/admispconfig/ispconfig/ispconfig.log

    any errors?
     
  16. zer0_g666

    zer0_g666 ISPConfig Developer ISPConfig Developer

    Ok ..

    There seems to be alot of info in there so i took the last WARN msg which says there is an error in the sytax of httpd ...

    11.2005 - 17:14:07 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2337: WARNING: could not httpd -t &> /dev/null
    17.11.2005 - 17:14:07 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2343: httpd syntax seems to contain errors, reloading with old configuration

    if u have vnc u can login and help fix if that would be easier ... just pm me
     
    Last edited: Nov 17, 2005
  17. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Don't worry about that warning. Nothing serious.

    That means that ISPConfig tried to write a new vhost configuration, but your Apache doesn't support all the features of that new web site (e.g. PHP, CGI, ...), maybe because some modules are missing. ISPConfig detects that and reverts the configuration back to the last working state so that your Apache can start. But this explains why you cannot see any of the sites you created in ISPConfig.
    Make sure Apache loads all the needed modules.
     
  18. zer0_g666

    zer0_g666 ISPConfig Developer ISPConfig Developer

    Amazing, its working!!! yey ....

    I installed a few apache2-mod's and bingo

    Thankyou
     

Share This Page