MySQL connect php-fcgi

Discussion in 'General' started by andypl, Apr 2, 2009.

  1. andypl

    andypl Member

    Next problem in last release ISPConfig.
    Problem is in connection to MySQL when websites have enabled php-fcgi.
    When the website have enabled mod-php can normally connect to MySQL.

    This is on error.log
    [Thu Apr 02 22:49:58 2009] [error] [client xx.xx.xx.xx] client denied by server configuration: /var/www/php-fcgi-scripts/
    [Thu Apr 02 22:49:58 2009] [error] [client xx.xx.xx.xx] client denied by server configuration: /var/www/clients/
    This is config apache virtual host:

    <VirtualHost xx.xx.xx.xx:80>

    ServerName domain.ltd
    ServerAdmin webmaster@domain.ltd
    DocumentRoot /var/www/domain.ltd/web

    ErrorLog /var/log/ispconfig/httpd/domain.ltd/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/domain.ltd>
    AllowOverride None
    Order Deny,Allow
    Deny from all
    </Directory>

    <Directory /var/www/domain.ltd/web>
    Options FollowSymLinks
    AllowOverride Indexes AuthConfig Limit
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /var/www/clients/client0/web1/web>
    Options FollowSymLinks
    AllowOverride Indexes AuthConfig Limit
    Order allow,deny
    Allow from all
    </Directory>

    # php as fast-cgi enabled
    <Directory /var/www/domain.ltd/web>
    AddHandler fcgid-script .php .php3 .php4 .php5
    FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
    Options +ExecCGI
    AllowOverride all
    Order allow,deny
    Allow from all
    </Directory>

    </VirtualHost>
     
    Last edited: Apr 2, 2009
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which exact URL did you enter in the webbrowser to connect to the site.
     
  3. andypl

    andypl Member

    Ok the problem with phpmyadmin fcgi is logging in with HTTP think of as set by the authorization cookie should be ok.
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Ok, you did not mention that you tried to access phpmyadmin, thats something completely different then that mysql is not working or can not be accessed! You can not access the phpmyadmin from the linux distribution when you use fastcgi as the linux distribution installs phpmyadmin in the wrong directory. The solution is to create a website in ispconfig and then install your own instance of phpmyadmin into it.
     

Share This Page